Home | Advertising Info56 USERS CURRENTLY ONLINE   
PowerASP
   Site Search Contact Us Saturday, May 21, 2022  

Active Server Pages help tutorial how to ASP Help ASP Tutorials ASP Programming ASP Code - ASP Free CJWSoft ASPProtect ASPBanner ASPClassifieds



Blog Entry: 3/25/2006 4:46:05 PM

I think you can either change some things in your PayPal account settings regarding your default currency..

or add a hidden variable to the PayPal form code ASPProtect uses like this guy did.
http://support.cjwsoft.com/code/code_info.asp?TID=237&KW =paypal

The hidden form variable code would go next to all the other hidden variables in no particlar order.. just look through the paypal code in notepad till you find a bunch of those hidden form variables lines in a row. ,
I had a question about user registration and how it works, mainly because I am having a problem.
 
When a user registers, with the email verification setting, I am assuming that there is supposed to be a new record created in the USERS table in the database. What could cause this not to happen?
 
Actually, in testing further I found that with the setting at Auto, Manual, or email, the record is not added to the table. And, if I am logged in as admin, the Add User button does not do anything.
 
I can however edit and delete user records...
 
Hmmm, adding a Category yields the same thing. And loggin in as a non-admin user still displays some of the menu items for admin, but then gives a page can not be found error if you click on one (ie, approve).
 
This looks like a db issue to me, I will have to try this with access and on a test server...
 
Any thoughts?
 
- Jason
 
 
cwilliams38303.8507291667,



Hi,

I can't seem to find the code where it limits the upload file size. I want to limit the upload size to 1.5 mg for all users. Also I've noticed that the 500 pix doesn't seem to work. As in if an image is bigger than 500 pix the script still uploads it. i am using Upload_post_VBSCRIPT.ASP.

Thanks

,

you do not run "check_user_inc.asp" by itself

Pages you protect include that file at the top.. when they someone goes  to a protected page if not logged in a user then sees a login prompt..

after loggin in they see that same page as normal

its an automated process..

now, that being said if you really want to you a specify a page to be redirected to after the 1st login when you edit a users info. You can also redirect anyone anywhere like using a simple ASP redirect statement in your code.

Personally I feel that redirecting people all over the place is poor site design. ASP is all about dynamic code and ASPProtect is all about dynamically tailoring pages to the current logged in users... so why redirect people all over the place.. it justs complicates things because you still need to password protect the places you send them to.... which means twice the work and twice the confusion.


Also, here is a Version 6 thread about redirecting manually that still applies to version 7.

http://support.cjwsoft.com/code/moreinfo17-1.htm

 

,

Hello,

Unfortuantely I can not help you much regarding the javascript because I am a server side code kinda guy. Client side javascript just isn't my thing. That was free javascript code that I used for that function. I really do not know enough about editing client javascript. Sounds like you might though.

Style 1 is really a relic left over from the standard version. I just left it in in case someone wanted to use it. Like I said because it is javascript making it do more than it does is tricky (at least for me)

Now,, for actually getting description code. The thing to do is check out how that all works in the pic_window.asp file which is what style 2 two uses. Bascially descriptions for an particular album get stored in one text file. We read that test file. Put the lines into an array. Then display the info which gets run through a functions to convert some special characters used when saving back to normal.

I tried to look at your site but it woulnt load for some reason.

 

cwilliams38420.0809259259,

Just to let you know that i figured out my problem. I had to modify the connection in the email code and get the correct path from my provider.

I hope you enjoyed your vacation.

Thank you
Adam

,

This isn't going to help you much but here is the deal.

The 2checkout support in ASPProtect actually is not supposed to work with 2checkout subscriptions and therefore does not need to use an item number.

It is intended to be used for single payments only with 2checkout as explained in this thread.
http://support.cjwsoft.com/code/moreinfo212-1.htm

Single payments with 2checkout use their shopping cart which allows for dynamic payments without needing an item number.

I agree with you that 2checkout's interface is confusing. It's actually about the worst system I have ever seen. I could not make a 2Checkout subscription system because their system is just too limited and I couldn't make it work the way it really needed to.

,

An email I just received from eastcoastguy.. to keep this thread up to date

 

 

Your quick reply was greatly appreciated... I removed the password and was able to use a DSN...I will look into a DSN-less connection later..once i get this working !
Cheers
 
eastcoastguy
 
 
 
 
cwilliams38146.6165509259, We are using this photo gallery to manage galeries of all the prodcut lines we carry, we have no use for users to be able to sign up so i hid that part of the pages, what i am wondering is how can i hide the rest of the navigational links and still be able to get logged in to admin.   Here is a link to the unfinished demo site.

http://www.scs-cases.com/photogallery/ 
, well, like I said.. I am leaving in about 5 minutes for the wedding.

If you put this up on a live server that I can connect to I will look at it tommoro for you. I have told you everything I could possibly tell you so I dont think your going to figure it out based on the things you have told me so far.

Only other thing I can think of is make sure your not running anything goofy on that server 2003 box. Norton Antivirus script blocking... various ad blockers.. anti spyware applications... etc etc... They can cause problems as well. , I wouldn't bother doing that. If pic uplading doesn't work it is most likely permissions to the directory pictures are uploaded to. If they are not set correctly it will not work. That dir needs the same permissions the database folder needs. , You do not say something like that in a support forum for a legitimate software product. I don't think piracy is funny in the least bit. It is something I deal with every day with my own software. If you want to joke about it please do it someplace else.  If you are downloading things via p2p do not talk about here. I don't want to know about it period.,

Just an update,,,

 

the permission were all correct.... i left it and tried from my pc at work and it works fine... so i dont know what hahhpened.... thansk for your quick response

 

regards

Domenic

Sydney, Australia

,

Hi, I am glad you like the system.
Thx for the comments..

The banner logic in aspbanner it tweaked for speed and performance.. that sort of thing really wouldn't fit into the current code structure very well. It would slow things down and be a nightmare to code because of the way aspbanner uses ultra fast application variables for the banner rotation. Basically its a feature I didnt incorporate for performance and pricing reasons.

I would suggest making different zones for different conditions.. then surrounding the banner calling code with if else logic so a different baner zone was called under certain conditions.

That way performance would not be effected and you could actually show a different group of banners based on certain conditions.

Sorry, but that is the best advice I can offer at this time.

I built ASPBanner for performance and at this time I refuse to sacrifice that for any feature that will slow it down and consume more resources.

cwilliams38383.5395601852,

I've got an ecommerce module that's running on it that uses access for the db.  Connecting into that thing is slow as well, but I figured that's because of the complications and volume it handles.

So as far as importing on a faster machine and copying it over to the server...what suggestions do you have?

,

Hello,

If you see that when doing a view source then that code is not running.

I will need to go into your site and look as something is very wrong on a low level and I have no more ideas.

PM or email me the info and I will figure out what is going on.

I'll need ftp or frontpage access to the site.
I'll also need to know the urls for the asprotect system as well as the page you are trying to protect.

CJW

cwilliams38229.7996064815,

When I attempt to upload, it appears that the image uploads. I get a "Original Image Size 0 X 0 pixels"

 

they don't appear in the web pages, any thoughts? I am using VBscript to upload, my host has safileup but I am unable to use it in this script, thanks for any help

http://mcintoshcounty.org/real_estate/extras/server_info.asp

here's the site link

Never mind, had the path to the image folder screwed up 

, Riiiiiiiiiiiiiiiiiiiiiiiight.

Even though I have a big disclaimer that the account is totally worthless without someone paying to activate it, the new IDs keep coming, about 3 a day.
,

The problem with that is when a user deletes an album, the album record does not get deleted from the DB, so counting all the records would return the accurate result. :(

 

Any hints?

eeye38433.0290740741,

actually  I just went to it again and it was somewhat slow coming up this time..

perhaps you have some issues with the sql database.

it should be instant.. like this one I run on my server
http://banserver.powerasp.com/aspbanner/

I suppose it could also have something to do with sql server resources but its hard to say..

 

cwilliams38319.7859722222,

Hello Chris,

I have switched to Alentus and have the permissions set correctly and Parent paths turned on.  I cannot figure out how to connect to the database.  Should I have the database in the aspprotect/data/database folder, or in the data folder that Alentus has in my root directory?  once that is determined, how do I decide what the path to that database is?  I have tried many things, but this is what the setup page tells me to enter in the data_conn file DBQ=D:\Websites\www.mysite.com\aspprotect\data\database\ASPP rotect_access2002.mdb;Driver={Microsoft Access Driver (*.mdb)};UID=Admin;Password=temp

Thank You

,

I checked the option pack code as well and it looks correct.
I tested it and it acted as it should.

You can see it in active at the live demo
http://www.aspprotect.com/demo3/demo.asp

admin
test

go the the admin area.. you will notice 3 users with level 4 access
1 of them is inactive

then go to the mass email area and pick   active and level 4
it will say it is sending email to 2 users which is correct

then go to mass email again and pick level 4 and inactive
it will say it is sending email to 1 user which is correct

choose any status and access level 4 and it will send email to 3 users which is correct

When you do this please realize you can not choose a group as well.
That will cause a problem because you can not choose a group and an access level at the same time.


Anyway... perhaps you can private message or use the contact us form and and let me take a look at your system. Since I can't reproduce the behavior that is the only way we might figure this out.

cwilliams38104.690787037,

You really can not do something like that. You can not use client side code to change a server side session variable.

To make changes server side a form must be submitted or a link clicked on to another page. Then you can do whatever you like but you cant have an onlci event update a session variable like that.

Though I am not sure of exactly what you are trying to do I think you'll need to go about things a little differently.

,

Okay, so I copied the txt file into the export file and tried the import users option and it timed out on me as well. 

Would it be easier to figure out if you were able to look at the iis server?

,

We would like to use some of the variables from the user account in our web pages after they log in (something like, 'hello <user>"), but for professional printout reports using company name and user.

Could you offer some help as to what variable string we use to print that information on logged in pages?

By the way,  the program is working great!!!

cwilliams38446.6302083333, ok,

LOL

,

Using "Email Authentication" as a registration option you cannot do that. There is no possible way I know of to have a delay on the authentication email like that. Also that method is not intended to involve any sort of manual registration like what you are doing.

Because you want to review people manually you need to change to registration process to "manual" and then send the email out manually from the users screen after making a user active.

,

I want to try this on the machine im using now; which is windows XP.

Is this possible? I don't think i can set folder permissions on XP... there is no option to do so...

Is there a way to do it?

,

Here is what I have in settings.

ServerSoftware Microsoft-IIS/6.0
ServerName www.107threnegades.com
ServerProtocol HTTP/1.1
PathInfo /gallery/gallery_admin
PathTranslated d:\hosting\arisky1\gallery\gallery_admin
FILE SYSTEM OBJECT Installed
ADODB (ActiveX Data Object) Version: 1.2 Installed  
CDONTS Version: 2.80 Installed  
SMTPMail Not Installed  
JMail Not Installed  
AspEmail Not Installed  
AspMail Not Installed  
SAFILEUP Not Installed  
Dundas Upload Not Installed  
ASPImage Not Installed  
AspJpeg Version: 1.4.0.1 Installed  
ImgWriter Not Installed  
Script Engine
Type VBScript
Version 5.6
Build 8515

I do not even see ASPUpload listed but when I run the test_asp_components.asp from the extras/more_component_info folder, it shows that it is installed.

67 Upload
Installed
Persits - ASPUpload
68 Image
Installed
Persits - AspJpeg

 

,

I had not rebooted after installing the Jet driver updates, so I tried that and the asptest page worked fine, and said that all the tests were successful and that the data connection was setup correctly. I then installed aspprotect again, but with the same results. I cannot log-in from the get_me_in.asp page. It still says that it is opening the page, but does not respons for an indefinite period. The asptest page is in the same directory.

I have looked for alternate databases for this product on your site, but I cannot seem to find them.

,

glad it is working now

sorry ya had trouble.

cwilliams38418.6886342593,

I would look on the pictures folder on the server and see what is there for pictures. Also, when you see a broken X on the site right click and see where it is trying to get the picture from and what the pictures name should be.

I would also be sure to clear out your temporary internet files in IE. clost and restart all browsers..

maybe show me the site ? so I can see this happening ?

cwilliams38348.9748726852,


If you want to have a login form on a non protected page that posts
to a protected ".asp" page use code like this.

Change the action of the form to the page you want them to log into.
Make sure to page you send them to is protected by the "check_user_inc.asp" file.


<center>
  <table border="0" width="400" height="200" bgcolor="#000000">
    <tr>
      <td bgcolor="#F4F4F4">
        <form method="POST" action="memberarea.asp">
          <input type="hidden" name="Status" value="Checkem">
          <p align="center"><font face="Arial">ASPProtect Login</font></p>
          <div align="center">
             <center>
             <table border="0" bgcolor="#C0C0C0">
               <tr>
                 <td bgcolor="#EBEBEB"><strong><small><font face="Arial">Username</font></small></stro ng></td>
                 <td><input type="text" name="Username" size="10"></td>
               </tr>
               <tr>
                 <td bgcolor="#EBEBEB"><strong><small><font face="Arial">Password</font></small></stro ng></td>
                 <td><input type="Password" name="Password" size="10"></td>
               </tr>
               <tr>
                 <td bgcolor="#EBEBEB" colspan="2"><font face="Verdana, Arial, Helvetica" size="-1"><input type="checkbox" name="KEEPMESIGNEDIN" value="True">Keep
                   me signed in on this computer unless I log off.</font></td>
               </tr>
             </table>
             </center>
          </div>
          <div align="center">
             <center>
             <p>&nbsp;<input type="submit" value="Login"></p>
             </center>
          </div>
       
        </form>
      </td>
    </tr>
  </table>
  </center>

, I see what your saying.. its just hard to troubleshoot something when a  lot of changes have been made.

Did you test things before you started modifying the code ?

If its SQL server it is very important that the database was created with the provided SQL scripts.,

Hello cwilliams, and thank you for the fast reply.

Well, i have tryed with the ASPImage enabled and disabled, with the same results. I have used gifs and jpgs in the tests.
I have made some different test. Some with uploading the picture over an excisting picture and some as the first picture. Same results.
Everytime, itīs the 2nd thumbnail that wonīt show itself, but the large picture will show, if you press the thumbnail.

I have tryed to look in the code (view_ad.asp), but as far as i can see, everything seems just fine ?!

I know, it wasnīt much help i could give you, but i think i have tryed all the possibilities.

Best regards, Erling

 


 

, Well my hosting company has finally gotten back with me, so I'm having them troubleshoot the webserver to see what might be eating up those resources.  So I'm in a holding pattern on this for right now.,

I have just started to move my sites to a new dedicated Windows 2003 box.  I have parent paths enabled, SSI turned on but I still can't get ../ to work with server side includes.  Everything I read online says that I need to turn on parent paths but again, they are already turned on.

The hosting company where the server is located can't tell me anything, they just say that that is the way it is with Windows 2003.  I don't buy it!

Can anyone tell me anything on this issue to help enable the ../ for serverside includes? 

,

Now I am having trouble using the log function. 

 

I have checked the box in administration area for UseLogFiles.  I have put the expected path for the LogFileDirectory in the box.  I have modified the permissions for the anonymous web site user to modify this directory.  However the log file does not get updated and there is nothing when I go to view the logs. 

 

thx

, Thanks and glad that fixed it.

You can review this software at
http://www.aspin.com/func/review?id=4952510

That being said, ASPIN has a lot of problems with anonymous reviews so if you can please sign up with them and post an Authentic review as they carry a lot more weight. Authentic reviews involve responding to their validation email so when doing so use a real email address that you regularly check.

And sorry I made you use the forums, but as you can see this is exactly the sort of thread that will help someone else later on.. and that is why I require people to use the forums now instead of just email support. That way the conversations are out in the open where they can help everyone instead of buried in my outlook where no one will ever see them. And of course if information is sensitive you can always do a Private Message as you did earlier.

It is all about creating a knowlegebase of valuable information.

,


Timecard Entry: 3/25/2006 4:46:05 PM

60 miles back to h2o, helped a user dowload and install 5.5 a user was getting disconnected, Fixing a problem with the IMC Frame Router. , busy morning. , Checked and called back customers that left voice mail messages., **Agency Ideas - tried to figure out why nt auth. wasn't working, IMC Net customer having problem w/ ISDN multilink. , worked on online signup and problem report pages for Customer Focus Group, added new access numbers map to Partners, GiSCO and GOGiSCO home pages, Travel back from Plattsburgh 162 miles, Had to drop Matt at work so I could have van, Talked to Ron, Jim, Nic about death of ZipLink dial up numbers. Called/emailed some boards to let them know that we no longer have dialup in their area., StLawrenceCounty.Org, BERNIECARR.COM FORMATTED PAGES UNDER THESE SECTIONS CLERKS OF THE WORK MUNICIPAL ENGINEERING BRIDGES AND HIGHWAYS LIBRARY FACILITIES SCHOOLS HISTORICAL RESTORATION MISCELLANEOUS PROJECT RESIDENTIAL , company holiday, Worked on distributor database., to Clayton, Pulled cards on the microcom in Clayton., Meeting for SoftMLS, assist customer with billing- andrea at lunch answer phones.Melvinrose new customer- info for web site/ sent info Randy- go over inhouse form for new accounts and maintenance Mel Mclear-Left message joe basta- billing statement- front page info April Fallon- info timberview- left message for john , Working on quote for Burlington., lunch, Rebuilt image links to ad photos,Edited/deleted ads for the Guide , Proposals for KVVI, Crown Point... voice mails, Ron, etc..., * Energy Initiatives development, invite list, got mailed out invitations, worked with Tim to fix an error on the work system, USA Datanet Meeting, 2 signups in a row. 5 minute hold time, voicemail, email, call backs, Premier Paging, Island tree company, Bruce Countryma, Hefferon Homes, Health Alliance, organized materials for designers to finish up CPH,

   Active Server Pages Rule The World
Contact Us  
All artwork, design & content contained in this site are Copyright Đ 1998 - 2022 PowerASP.com and Christopher J. Williams
Banner ads ,other site logos, etc are copyright of their respective companies.
STATS Unless otherwise noted - All Rights Reserved.

Active Server Pages ASP ASP.NET .aspx .ascx Web HTML Developer Internet Microsoft Web Services Visual Studio .NET CJWSoft ASPProtect ASPBanner ASPClassifieds www.aspclassifieds.com, www.powerasp.com,www.cjwsoft.com,www.aspphotogallery.com,www.codewanker.com,www.aspprotect.com,www.aspbanner.com