Home | Advertising Info59 USERS CURRENTLY ONLINE   
PowerASP
   Site Search Contact Us Saturday, May 21, 2022  

Active Server Pages asp search engine active server page asp application components tutorial CJWSoft ASPProtect ASPBanner ASPClassifieds



Blog Entry: 3/25/2006 4:58:25 PM

The ASP error on the home page has been solved -There was aproblem with the path that was including the home page file and we fixed it.

However the error on the member page remains - any ideas/suggestions would be appreciated. This is the error:

Microsoft OLE DB Provider for ODBC Drivers error '80004005'

[Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for

process 0x748 Thread 0xad8 DBC 0x214734c Jet'.

/aspboard/forum/global.asp, line 15

 

,

Banners no longer show up on my site ?

If banners were working fine and now they are just not showing up.
1st check to see that you are calling a valid zone with live banners in it.
If you are then most likely this it what hapened.

The web server must have crashed or lost power and now the application variables are in limbo/not working.

I have seen this happen 3 times. Twice on my own server when the power went out for 2 hours and once on a customers server.

Basically the application variable system gets all messed up because it was not shut down properlly.

The ways to possibly cure it are as follows.

 

Edit and save a banner in the system. Hopefully that gets things going again.
If not... keep reading for the more drastic cures..


Go to the command prompt on the server and type "iisreset"
Sometimes that is enough.

Reboot the server.
Sometimes that is enough.

Stop the web in the IIS console.
Sometimes that is enough.

Stop the individual processes for each web in iis
"you must really know what you doing and be very careful about doing this"

Remove and recreate new applications in IIS for the web in question.


And sometimes it just takes a combination of the things listed above and a few reboots. I don't know the best way to cure it but I do know why it happens and the steps listed above can get things back on track.

Again, this is because the server lost power or crashed as far as I know.
It was not allowed to shut down properly which sometimes happens.

You'll know things are ok again when you see your banners show up on your site.

cwilliams38295.0183101852,



this could go on forever...

if you want PM "private message" me info to log into your site.. show me the pages we are dealing with...

and I will take a look at it all...

CJW

,

well, I need more details..

you got SQL server or data connection issues is pretty much the bottom line

If I remember right we went down this road with a SQL setup quite a while back (auguest 2005) and that never really got resolved

here it is
http://support.cjwsoft.com/code/code_info.asp?TID=321&KW =yiak

 

 

, you would have to edit the application in visual studio.net.. change some things around  and recompile the application... in the process figuring out how you want to handle all of that (probably combining the username and email fields just on the registration form then saving both values to the database)

very doable.. just not anything documented or supported as it is custimization

I do have a very  nice article on the forums on how to set up a project in visual studio.net with the application..  it is in the forums,

I'm having an issue importing. It moves the images from the /import folder and creates the thumbnails with no problem, but the full-size photos all have a size of 0 bytes.

http://www.larrysampas.com/gallery2/default.asp?CatLevel=2&a mp;Cat1_ID=1

,

On the banner rotation order screen it says:

"The Order Of These Banners Will Change Randomly From Time To Time"

Can you tell me the function that does this? I'd like to increase the frequency with which the rotation order changes.

Thanks!

,

It sounds like permissions... to the database folder specifically
they are not correct

It could also be that your odbc drivers are very new and you are not using a new enough version of the access Database. I recommened using the 2002-2003 verison of MSACCESS


Now.. if using a SQL Server Database permissions to certain tables are handled in enterpise manager

cwilliams38303.5892708333, I'm using Groups and would like to assign all new users to a particular group.  How is this done? cwilliams38298.5087384259, I need more details... telling me you cant get it to work doesn't give me much to go on , look in the "check_user_inc.asp" file

try editing this part by hard coding the body info you want to use

 Response.Write("<BODY" & Application("BodyTagInfo") & ">")


I would also suggest reviewing the generated source code in the web browser and examining the html to figure out exactly where the body tag info you dont want is coming from
,

For some odd reason, the the export path has two backslashes (\\) at the end, thus generating an error each time I try to export. For example

C:\path\website\protect\data\export\\

This appears toward the bottom of the import_export_manager.asp page and is called by =ExportDirectory.

I checked under settings tab, no path ends with a "\". Any idea where else I need to look?


Nick

 

, well, for now you have to watch the logs. What your talking about would take up a lot of server resources and database space to keep track of. Maybe some day, but no plans at the moment.,

The "forgot your password" feature is not sending passwords to users when they put in their emails.

Any suggestions?

Thanks

, I have no idea of what kind of 'stuff' to try. I'm running other asp apps that use there own Access databases with no problem whatsoever., YAY FOR ASPPROTECT 7!!!

Now I need to know... how can I automate PayPal subscriptions and purchases? I'd like it so that once PayPal gets its money, my accounts get marked active.

Now, the documentation on this site currently says, to point the IPN post action to a null page. Yet, I see an IPN.asp in my files for PayPal subs and PayPal purchases...  Looking over the code there, I see actions to make accounts active and stuff like that. Is the page ready for prime time, or should I hold off for a new version?
cwilliams38421.7014814815,

I was actually able to do similar thing by allowing our dedicated search engine to access the site unchallanged.

<%
If Trim(Left(Request.ServerVariables("HTTP_USER_AGENT"),11)) = "MYPASSWORD" Then  
 SearchFlag = True
End If
 
If SearchFlag <> True Then
If Session("Access_Level") > CHECKFOR or Session("Access_Level") = "" Then 
%>
<!--#include virtual="/Auth/check_user_Code.asp" -->
<head>
<title>My Title</title>

</head>

<body>

My Protected stuff here

</body>

</html>

For this to work, the search engine must pass the PW to the web site. I just was not sure how to do the same thing with IPs. I will play with the code and see what happens. If it works, I will post it here to help others, if this is OK with forum rules.

Thanks,

Mo

, Will purchasing an additional license resolve the issue which will allow another installation or is this a function of the application that it can only protect one site per server?,

Chris, that fixed it.  Found 2-references to guestbook2 in the file show_messages_inc.asp located in the \guestbook\ directory.

Suggestion for future release.  Create an option to email the admin when a message is posted.  If this code already exists please advise.

Thanks, Lance

, After a user edit his information (name, email, etc), the session variables are not updated.  In the user_area.asp page, I "Response.Write" all the session variables, and they are still showing the old information. I tried refreshing the page but to no avail. The only way to update the display is to log off and login again.

please help.
,

I just moved servers and now my "code" ads are giving me errors...

"google_ad_width" is undefined.

I have tried adding the width and height... taking it out.. all the basic stuff.

Any ideas?

TIA  

,

Sounds cool.. post info when you get it sorted out

thx

hopefully someday I'll get the new version finished.. I just never seem to have time. Lately ASPProtect takes up all my time and now aspclassifieds seems to be in need of a new version more so than asp photo gallery

 

,

I really need more info on what you have going on?

This can sometimes be cause by a slow server / bad data connection.

Sometimes caused when someone is using the option pack but did not make the proper changes to the database.

Sometimes caused when a user adds users the database on his own and does some "incorrect" things..

The more details you can provide the better. Think of anything and everything and describe it.

SQL or MSACCESS... version of either
Server OS
Using Option Pack or not
Did you have your host set permissions...

etc etc etc

cwilliams38300.5380092593,

I'll try to help when I get back tues night,, see the contact page for info on where I am
http://www.cjwsoft.com/contact/default.asp?Subject=CJWSoft+G eneral+Inquiry

,

ASPProtect v7.x has a new feature called groups.

Groups are meant as a replacement for using the access levels as they are much more powerful. Support for pages protected using access levels is left in tact for backward compatiability for a customer that was using them.

A customer recently told me groups could not be used like access levels and that 8 access levels was not enough. This is how I explained that groups can do everything access levels can do.



Groups can honestly do everything access levels can do if you really think about it.
Using groups and protecting pages accordingly you could actually create a system that basically worked identically to the way the access levels works.

For example..

You make 8 groups and assign users to them accordingly


Protection code on page allows access to groups 1-8
The aspprotect system generates this code for you…

<% GROUPACCESS = "1,2,3,4,5,6,7,8" %>
<!--#INCLUDE FILE="check_user_inc.asp"-->

In this case a user assigned to any one of those groups would have access..

 

Protection code on page allows access to groups 2-8
The aspprotect system generates this code for you…

<% GROUPACCESS = "2,3,4,5,6,7,8" %>
<!--#INCLUDE FILE="check_user_inc.asp"-->

In this case a user assigned to any group between  2-8 would have access..

 

Protection code on page allows access to groups 3-8
The aspprotect system generates this code for you…

<% GROUPACCESS = "3,4,5,6,7,8" %>
<!--#INCLUDE FILE="check_user_inc.asp"-->

In this case a user assigned to any group between  3-8 would have access..

and so on... I think you should get the picture by now

, you can whatever you like but like I said those gif files are already in the correct place. The log parser is messing up. ,

I think you getting all confused about dsn's and what they really are.

A system dsn gets created via the ODBC control panel and gets listed there. A system dsn is nothing more than a registry entry telling information about where the database is an how to connect to it. Then every time code accesses the database it has to do a registry lookup. The whole process adds a lot of delays, causes very poor performance and is unnecessary.

A dsn-less connection simply connects directly to the database by specifying the driver being used, where the database is, and some other information like the password if there is one.

To get aspprotect or any other ASP application using a database all you have to do is make sure the database folder has correct permissions and then make a connection string like so. (with the correct info for your directory structure of course)

DBQ=c:\inetpub\wwwroot\aspprotect_6\data\database\ASPProtect _access2002.mdb;Driver={Microsoft Access Driver (*.mdb)};UID=Admin;Password=temp

If you are wondering Access databases always use the same username.

So, basically if permissions are set correctly and the directory is valid it will work.
It is really that simple. 99% of the time when people have problems it is one or the other.

That being said, don't worry about the odbc control panel and what is listed there for connections. All we really care about is that odbc drivers are installed and somewhat current.


One last thign for reference: even if you do make a system dsn the database folder still needs the correct permissions.

cwilliams38417.7371643518,

Trying to make sense of this.  I am still confused.  In the file config_inc.asp.  I found the setting for "uploaddirectory".  That entry looks like this [UploadDirectory = CmdGetConfiguration("UploadDirectory")].  I assume there is a config file where the value of upload directory is located. 

The settings in the config_inc.asp file have not been changed.  they are set to the way it was delivered.  Is there a document that gives instructions as to what and where the config settings are to be changes?

, ok, glad it is working,

It should be released sometime late May 2004 or early June 2004 but no gurantees as I am pretty busy right now with some projects.

There will be upgrade instructions and it should be a fairly easy upgrade.

,

Upgrade from V6 to v7.x with an MSSQL SERVER DATABASE

1st of all, backup your existing ASPProtect files and database before performing this upgrade. Please be really careful while performing this upgrade. Version 7.x  is a highly advanced application compared to any previous versions. CJWSoft under no circumstances is responsible if you lose information or have website downtime.

BOTTOM LINE: (PERFORM THIS UPGRADE AT YOUR OWN RISK)

To do this upgrade you're going to need to have SQL Enterprise Manager and SQL Query Analyzer

That being said, on with the upgrade..


Open your SQL database in SQL Enterprise Manager

Regarding the following Tables

Rename "Users" to "ASPP_Users"
Rename "Groups" to "ASPP_Groups"

If you do not have a "Groups" table do not worry about it right now.

Now right click and DELETE the Config Table.
Yes, delete it..

Now, go into Design View for the "ASPP_Users" Table.

Rename the "Password" field to "Old_Password"
Be sure to spell it perfectly using the Underscore

If you have a "Groups" Field... leave it alone
If you do not have a "Groups" Field add one and make it a "nvarchar" field with a lengh of 255.

Now, we are going to add a few more new fields.

Add a field called "Redirection_URL" make it a "nvarchar" field with a lengh of 150.
Add a field called "PayPal_Subscriber_ID" make it a "nvarchar" field with a lengh of 100.
Add a field called "Newsletter" and make it a "bit" field
Add a field called "Password" and make it a "nvarchar" field with a lengh of 100.

Now close that window and save the changes..

Download these scripts.

2005-02-23_171110_aspprotect_v7_sql_upgrade_scripts.zip

Now open up SQL Query Analyzer
Connect to your SQL server.

Then load the script  "aspprotect_v7_config_table.sql" into the Query Analyzer.  Click the green play button at the top. If everything goes well the response should read something like this.

******************************************************
(1 row(s) affected)
******************************************************

Now, if you had a Groups Table your done with the database changes.

If you didnt have a groups table.

Then load the script  "aspprotect_v7_groups_table.sql" into the Query Analyzer.  Click the green play button at the top.

Now, go back to your database in Enterprise Manager and make sure all 3 tables are there and look ok. You might need to do a refresh or two to see them.

Now make sure an existing or new SQL user has (public / datareader / datawriter) permissions for all three tables. You reference this user in the asp code connection string so this user must be set up correctly. You may need your SQL server admins or hosting company to help you on this step as you may not have access to do this. You may not need to create a user and set permissions as the sql user you were logged in as to use query analyzer may by default get the correct permissions on anything you create.

Regardless, as you can see from this screenshot I have a SQL user called "aspprotectuser" and proceeded to set the permissions for that user. Under database access giving him (public,datareader, and datewriter permissions).


Now, you are done upgrading your SQL Server Database.

The existing passwords still have to be encrytped and moved from the "Old_Password" to the "Password" field

To that we have a special page we run in the application that will take care of that.

So, for now... go install the application, but using the database we just created.
Follow these instructions for the most part...
http://support.cjwsoft.com/forum/forum_posts.asp?TID=181& ; ;PN=1

When you get to the part where you finally get into the admin area and need to make an admin account you will notice that your existing user database is there but none of the users have passwords if you look at them in the edit screen.

That is normal. Simply do what the instructions say and create and admin account using a username that does not exist..

Then log off... then back in as that new admin account. If that works you are ready to convert the passwords.

This part is very easy.

You want to run a special page via the browser.

http://www.mysite.com/password_admin/convert_to_encrypted.asp

Replacing the part in blue with your website info.

Once you get the page running you will see a login prompt and one form field just like before with the "get_me_in.asp" page

You will need to paste the "PasswordEncryptionKey" value that you used in the "config_inc.asp" file in the form field and hit enter.

If all goes well you will see a page telling you to click here to encrypt the passwords and copy them over.

So do what it says... dont click more than once and wait.

Eventually it should say it is finished. So go log in to the admin area of the system using the new admin account.

Now edit some users but dont save... you want to see if the passwords are showing up. If they are the conversion worked. If you see nothing or a garbled mess it did not work and you made a mistake during this whole process.

If things went well backup and delete the conversion file below.

http://www.mysite.com/password_admin/convert_to_encrypted.asp

You do not need it anymore.

Once you are positive every thing is running smoothly and everyone's passwords are ok you can go in and delete the "Old_Password" field as well.



If things didnt go well.. try again from scratch and go slowly.
If they still dont go well get ahold of us for help.

We are here to help, but if you really want us to we can be hired to do the conversion.

,

the sql databse is the same.. the sql script is the same for any version

as the site says they are essentially the same app with very minor changes... if you are trying to share the same sql database with both it's not gonna happen because the table names are the same

truthfully:
that app runs nealry as well with msaccess as it does with sql so I wouldnt get too excited about running it withe sql. You will not see any benefits unless you have a ton of simultaneus (sp) users.

cwilliams38312.1125115741,

yes, How can I have fixed size height and width image without distortion. Is there a component that I can use or how can I change the existing code.

 

 

 

yes, unless its ratio matches

how could it not be ?

Please keep questions like this in the forums... thx.
there is no need for this to be a private message


-- Previous Private Message --
Sent by : eeye
Sent : April/29/2005 at 2:19pm


If I choose fixed width and height is the thumbnail image going to be distorted?

-- Previous Private Message --
Sent by : cwilliams
Sent : April/29/2005 at 1:17pm

that is not possible unless you rewrite the code.

You onlyahve the two options we give in the config file for thumbnails

fixed width and height all the time

or

fixed width / dynamic height



-- Previous Private Message --
Sent by : eeye
Sent : April/29/2005 at 1:07pm

Hi William

One more questions for you. is there a way to make sure that all the thumbnails are the same size without distorting the images (in the thumbnails). Or if a picture's height is bigger than its width is there to create the thumbnail such that the height of the orginal becomes the width of the thumbnails and vice versa.

Basically I just want the thumbnail pictures to be in a perfect row with all the picture heights the same and all the pic width the same.

Thanks

Sean

,

I am running .asp pages and using the longer code method to display flash banners on my site.

I have noticed a considerable decrease in the loading of my index page when I have a banner called.  When I remove the banner, all is fine.

Any suggestions?

Dave

,

I do not think it it anything to do with the Application.

You most likely have some sort of ad blocking software that is doing it.

It is seeing the word "banner" or "ad" and blocking the images in your browser.

I doubt it is anything built into xp doing it. XP with SP2 has built in pop-up blockers but no ad blockers like that really. It is norton ad blocker or something of that nature.

,

ummm.. ok.. Then this doesnt make sense.  On two out of the three machines I have in house here, the images do not show up.  They only show up on the server machine.  I am using the constant url on all three machines.  www.rfamilystuff.com  Does it show up on your?

 

,

No can do.  In both cases there is an icon that says "Not uploaded".  I click in it and nothing happens.  There is no link to upload.  Am I missing something?

By the way, I appreciate and am impressed with your rapid response. Thanks.

 

 

,

It's custimization work. and just not something I can support.
Basically it is basic ASP/Database work.

Something you kind of need to figure out on your own. It's not difficult work for a good asp coder but there is no easy way and it is time comsuming.

I wouldn't use the custom fields though. I would make your own.
It's simpler that way.

cwilliams38437.0929282407,

I think you may be using old code where that was an issue... I am going to PM you the latest version..

to be safe upgrade all the ASP files except the dataconn_inc.asp files and your config_inc.asp files

"be real careful not to lose your current encryption keys in the "config_inc.asp" file or you will be in real trouble

You can use your existing database

 

,

Ok, so I checked to see if ASP is running on the server and it is.  then I added code to the top of a page and this is what i can see when 'view Source' on the web browser:

<%@ LANGUAGE="VBSCRIPT" %>

<!-- Begin ASPProtect Code -->
<!-- Groups with access to this page. ( * Admins * ) -->
<% GROUPACCESS = "4" %>
<! #INCLUDE FILE="check_user_inc.asp">
<!-- End ASPProtect Code -->

<html>
<head>
<title>TeamManagers</title>

Yet I get no challenage for a password and no error message!

 

 

,


Timecard Entry: 3/25/2006 4:58:25 PM

Pre-school comp., Lunch, Calling people back on voice mail, responding to e-mails. Starting backup of servers., Answered phones and checked online reports., working on association tables for the TIITC, IPRS issues w/ Verizon. Working on getting it working. Working w/ IROC and DSC, went to randy's house and then to ogdensburg to pete cliff's house with ben, ODMLS db conv., Tried to get photoshop file to transfer to label document. helped bc with excel a bit. talked with bob crane about channel partner program. , Channel Partner Invites..., Answered phones, called a couple open incidents back and checked RadLog, Emonitor and Dial Up Issues., Doing a wireless survery from the general area for Pete's restraunt. NO WORK ORDER CREATED YET!!!!!!!!!!!!!!!!!!!!!!!!!, Modem, Network & Domain Maintenance, Doing the reports that I was to busy to do before....back bone and modem reports. It's been a VERY long day........going to SLEEP.....maybe, Marketing, pre-sales meeting w/Dave Mcbride @Fleischer, Jacobe and Associates, IMAGEREADY, Citec conference, radlog, phones, , Went to the bank and post office-petty check and tax check, mostly tech calls on Lowville i called logical net about the issue and left a voicemail... about 4 hours later it still was not fixed nor had i heard anythin from the technicians so i sent an email about the issue to Dan, Travel to Boonville, troubleshot a permissions problem (w/Tims help) on the Dynoport storefront for Lisa, cancels, Meetings, went over some changes with chris williams onsofl mls, helped paul to get back on network, timmy broke his computer that was running dhcp for paul. setup dhcp on steves machine for now , will build and take over a puter for clayton server or put on a dhcp on router with an upgrade., Answered Phones and nomral Tech duties. A few things went red, and yellow, 2360 was down for a tad... otherwise things were hunkydory, Team meeting, filed,

   Active Server Pages Rule The World
Contact Us  
All artwork, design & content contained in this site are Copyright © 1998 - 2022 PowerASP.com and Christopher J. Williams
Banner ads ,other site logos, etc are copyright of their respective companies.
STATS Unless otherwise noted - All Rights Reserved.

Active Server Pages ASP control controls class classes module script Scripts applet CJWSoft ASPProtect ASPBanner ASPClassifieds www.aspclassifieds.com, www.powerasp.com,www.cjwsoft.com,www.aspphotogallery.com,www.codewanker.com,www.aspprotect.com,www.aspbanner.com