Home | Advertising Info77 USERS CURRENTLY ONLINE   
PowerASP
   Site Search Contact Us Sunday, August 18, 2019  

Active Server Pages what is asp programming how to sample asp example code scripts software asp forum mail sessions applications global.asa CJWSoft ASPProtect ASPBanner ASPClassifieds



Blog Entry: 3/25/2006 4:39:51 PM

After taking another look at this and trying your suggestions without success, it appears that in Windows 2003 server it is nearly impossible to remove the READ ONLY attribute from the _database folder.  I'm wonder if this could the cause?

Thanks 

, Here is an example of a query I made in MSACCESS that deletes all users that belong to Group ID of 3. I used the graphical query designer in MSACCESS to do this. Took a few minutes.

DELETE
FROM ASPP_Users
WHERE (((InStr([ASPP_Users]![Groups],"*3*"))>"0"));

Because of the way groups are stored in the Groups fields you have to use the InStr function to determine if the user is part of a particular group
We are deleting all users that of Group ID of 1 so we look for *3* in this example

The SQL statement for a MSSQL database may be slightly different but the general Idea is the same


The SQL statment used in an ".asp" page will be very similar as well.

SQL Statements are the TRUE POWER of working with databases. They are something everyone should learn to work with because they allow you to do some very powerful things.,



sounds like trouble with the SQL database.

Did you create it using the SQL scripts we provide as that is extremely important ? , Very weird for sure but I guarantee no code in ASPProtect is deleting that folder. Something else is going on the server and deleting it and I have no idea what it would be.

Maybe try leaving a blank text file in it and see if the folder disappears after a few days.,

These are 4 valid examples of calling a flash movie.

The more simple examples may cause problems for people that don't have the flash plugin installed. I really do not know as I am no flash expert. All these work fine for me. Of course I have the latest flash plugin installed. Perhaps some of you can shed some light in this. The 3rd and 4rth examples are obviously only slightly different and mention different versions of flash as far as downloading the plugin goes.

 

<EMBED src=" http://www.aspbanner.com/test/aspbanner/images/banners/power asp.swf" WIDTH="468" HEIGHT="60">

 

 

<object width="120" height="22">
<param name="movie" value=" http://www.aspbanner.com/test/aspbanner/images/banners/power asp.swf">
<embed src=" http://www.aspbanner.com/test/aspbanner/images/banners/power asp.swf" width="468" height="60">
</embed>
</object>

 

 

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase=" http://download.macromedia.com/pub/shockwave/cabs/flash/swfl ash.cab#version=6,0,40,0"WIDTH="468 " HEIGHT="60" id="myMovieName">
<PARAM NAME=movie VALUE=" http://www.aspbanner.com/test/aspbanner/images/banners/power asp.swf">
<PARAM NAME=quality VALUE=high>
<PARAM NAME=bgcolor VALUE=#FFFFFF>
<EMBED src=" http://www.aspbanner.com/test/aspbanner/images/banners/power asp.swf" quality=high bgcolor=#FFFFFF WIDTH="468" HEIGHT="60" NAME="mybannername" ALIGN="" TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer">
</EMBED>
</OBJECT>

 

 

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase=" http://active.macromedia.com/flash2/cabs/swflash.cab#version =4,0,0,0" ID=banner WIDTH="468" HEIGHT="60">
 <PARAM NAME=movie VALUE=" http://www.aspbanner.com/test/aspbanner/images/banners/power asp.swf">
 <PARAM NAME=quality VALUE=high>
 <PARAM NAME=bgcolor VALUE=#FFFFFF>
 <embed src=" http://www.aspbanner.com/test/aspbanner/images/banners/power asp.swf" quality="high" bgcolor="#3CBDCD" WIDTH="468" HEIGHT="60" TYPE="application/x-shockwave-flash" PLUGINSPAGE=" http://www.macromedia.com/shockwave/download/index.cgi?P1_Pr od_Version=ShockwaveFlash">
</OBJECT>

cwilliams38089.6129513889, I just remembered the current skin is stored in a text file in the pictures folder. If it did not have permissions for writing it could give you trouble.  That could of had something to do with it.cwilliams38295.3821064815,

On second thought guys, it would must easier to change the code using modulus as follows:

<% If PicIndex mod 6 = 0 THEN %> 
      </tr>    
      <tr>
<% End If %>

This will end each row and create a new row after each 6th picture. It'll be must easier code to work with and change.  This code must be placed in the PicIndex For Loop.

If you have any questions, JPortnoy@Checkernet.com

,

enjoy the bar.. drink one for me.. cause that was the problem..

 

,

I am trying to protect and ASP page written in Javascript.  The first part of the page goes:

<%@LANGUAGE="JAVASCRIPT"%>
<!--#include file="../Connections/connWINGAP.asp" -->

When I insert the aspprotect code it looks like this:

<%@LANGUAGE="JAVASCRIPT"%>
<!--#INCLUDE VIRTUAL="/GIS/WCGIS/GISProtect/check_user_inc.asp"-->
<!--#include file="../Connections/connWINGAP.asp" -->

and I get this error: 

Microsoft JScript compilation error '800a03f7'

Unterminated string constant

/GIS/WCGIS/GISProtect/check_user_inc.asp, line 2

I think I understand that your code is written in VBscript and that is why it is not working.  If this is the case, how can I switch to VB to execute your stuff then switch back?

Thanks,

Jess

, and when I go to your now.. its very fast again..,

If you re-start the web via IIS, reboot the server, or (possibly) just add and remove a category... that will clear up.

ASPClassifieds and ASPListings must be installed in seperate IIS applications if they are the same web. Otherwise the category caching system of each system will interfere with each other. They were never intended to be installed in the same web together since ASPListings is merely a stripped down version of ASPClassifieds and they share a lot of the same code. Like I said though if different IIS applications are set up in the web site you can do it because each IIS application will have it's own set of application and session variables.

,

It happens at least once per hour or every time a banner is edited in the system by the admin.

Changing its frequency would be somewhat complicated. You'll have to make changes to the code in a few places and you will effect performance adversely by doing it more often as it will mean a lot more database queries which defeats the purpose of doing it once per hour to conserve resources. The reason is when you change the frequency of that you also change the frequency of the entire banner application variable caching system. It difficult to explain but it unlike most banner systems out there it basically fetches banner rotation info every so often instead of every single time your page needs a banner. It stores this rotation and cycling information in ultra fast application variables. The docs actually go over a little bit of how that process actually functions under "using the system / Setting Up Banners
"

Its a customization I just can not support and I do not recommend doing, but if you really want to you should look at the "aspbanner_inc.asp" file

this is the part that makes it happen at least once per hour (requires visitors to your site to happen obviously)... you'd have to cleverly recode it to work slightly more often

' Checks the time the banner data was last updated and basically updates it if an hour or more has passed
If Cint(Application("BannersLastUpdated")) <> Cint(Hour(time)) Then
%>
<!--#INCLUDE FILE="appinfo_inc.asp"-->
<%
End If


There may be more to changing this than that, but this is all I can tell you.

cwilliams38441.6427083333,

If you are using an ACCESS Database try to avoid using a system DSN. They are much slower because they go through ODBC which then uses the Jet Drivers to access the database. They also have to do a registry lookup.

ttp://www.4guysfromrolla.com/webtech/070399-1.shtml

http://www.powerasp.com/content/database/dsn_vs_dnsless.asp



It's funny because in the 4guys article they ask the question..

"Hmmmm... so who was right, Microsoft or Wrox?"

I'll tell you who was right and who said it 1st.  It was me and I said it on my old powerasp.com site before anyone else ever did.

I found it out on my own by experimenting when I was the Systems Analyst for an large ISP. We we had web servers that were not running well. I didn't read about this solution anywhere because no one was talking about it at the time. Microsoft said use System DSN's so everyone just took their word for it.

I took a lot of heat for saying that back in the day but over time everyone started saying it.

, MODS are NOT SUPPORTED.. questions about them will not be answered in the support forums. If you want to use a MOD you are considered an advanced user and will need to sort out any issues that may or may not come up.

MODS are used at your own risk and may or may not require certain basic coding skills. ,

Hello Chris,

I have switched to Alentus and have the permissions set correctly and Parent paths turned on.  I cannot figure out how to connect to the database.  Should I have the database in the aspprotect/data/database folder, or in the data folder that Alentus has in my root directory?  once that is determined, how do I decide what the path to that database is?  I have tried many things, but this is what the setup page tells me to enter in the data_conn file DBQ=D:\Websites\www.mysite.com\aspprotect\data\database\ASPP rotect_access2002.mdb;Driver={Microsoft Access Driver (*.mdb)};UID=Admin;Password=temp

Thank You

,

I'll give it a shot within the next day or so. I'm busy with a few other things right now.  You're right about just saving a copy before I start. It can't really hurt anything.

Thanks Chris. I'll let you know how it turns out.

-john

 

, "get_me_in.asp" just hangs during a new install. Nothing happens no matter how long you wait and IIS may temporarily hang up as well.

You may very well be running something like norton antivirus with norton script blocker on your server? Or something similar?

It can cause issues when ASP uses the filesystem object and cause never ending page hangs like you are having.

Read this..
http://www.aspfaq.com/show.asp?id=2180,

Just to put an end to this thread here is the solution for anyone reading.

The permissions were ok.

The data connection string never got edited in the "dataconn_inc.asp" file so it was invalid the whole time.

Once that was corrected the application ran.

So really this whole thread was over not following the directions and not editing the data connection string... 

 

,

ok, I just sent you a private message with download information.

replace you existing

"check_user_inc.asp"

"admin/check_admin_inc.asp"

"admin/email_user.asp"


with the new versions in the download

Do some testing to make sure that HANNAH password works ok for you.

Hopefully this cures the issue...
If it works ok for you for a while I will offer the fixes to everyone and start using this code from now on

BTW:
"admin/email_user.asp" had an unrelated bug in it that only happened if its error handling got triggered... it was posting back to the wrong page when that happened and causing an error

,

Does emailing work under the simplest scenario ? (directly from the users screen)

Thats the way to test it..

All that error means is whatever reason the settings you have chosen are not working. It could be the server. It could be what you chosen. (and yes I realize your pop info from outlook should probably work with the settings you chose)

Whenever I do installs I often have to try 3-5 different emailing scenarios before I come across one that works.

Each time making some changes and sending out test emails from the users screen until I get somewhere. Often time getting a working example of how your Hosting Company wants you to send email from ASP is the info to get your hands on. (what method and settings)

In this case they may have blocked the usee of a remote server and want you to use some other settings for sending email from asp. A lot of times they put that info in their help system.

If I were you I would start by trying the other two CDOSYS options for starters, and then try the remote server option again but using "localhost" as the server, if none of those work consult your host for example code and settings to send email from asp. If you still have no luck I can help for sure.

Realize too when testing the emails may take a bit to arrive. A delay of sorts. Best to type in a quick note about which method you are trying in the email text. That way when you finally get one delivered you'll know which method worked.

,

lmao ... ya that has never happend to me before....

,

humm, did you edit any of the registration code ?
this is not something anyone has ever mentioned and the aspprotect 6 code has not been changed in over a year ?

can I see where there is happening ?
I may need ftp or frontpage access to the server in order to troubleshoot unless you can provide me with more details here.

thx..

,

Okay, I did that, now I get:

Microsoft VBScript runtime error '800a004c'

Path not found

/aspprotect/password_admin/upload_post.asp, line 292

,

I assume that if I am using this product, search engines such as Google cannot access and index my content. Can somebody confirm that; I want to be 100% sure.

In case it matters, I am using a basic, cheap ISP setup where my site is on a shared server.

Thanks in advance.

,

I'm in a bind cause I'm supposed to be launching on Monday!?  I have four different subscriptions set up in ASPProtect and I'm going to 2Checkout for payment.  When I go to 2checkout I have the same 4 subscriptions setup. 

How does ASPProtect know what product id to use in 2Checkout? 

I have the redirect setup etc. but it's using the default URL in 2checkout and not the product(Subscriptions).  The only way I can tell what the user selects is from the price... and I'm specifying the time period, the cost, group in the 2checkout1.asp but I'm not getting the user set for the periods either....  my main problem is the interface to 2checkout... I think if a product id is added somehow it might work.  What can I do?

thanks, -Jason

, ok, now were getting somewhere

I didn't know you imported from another system,

chances are you are missing field information that an ASPProtect user requires.

Start off from scratch with a new aspprotect database... create a new user and look at the info that gets entered by default for every field in the database

make sure when you import a user that you mimic it all

dont import directly using access because the passwords will not get converted to encrypted versions of themselves correctly.. and the whole process will be usesless as no passwords will be correct

Use the import feature built into ASPProtect.. because it is smart enough to take the clear text passwords and encrypt them accordingly

if you want to know a correctly formatted import file needs to look like make one and check it out

do one user at a time and make sure you can log in to an example protected page till you get it right...

once you get that working do them all

Thats really the best advice I can give you. , We are using this photo gallery to manage galeries of all the prodcut lines we carry, we have no use for users to be able to sign up so i hid that part of the pages, what i am wondering is how can i hide the rest of the navigational links and still be able to get logged in to admin.   Here is a link to the unfinished demo site.

http://www.scs-cases.com/photogallery/ 
, Message :

I purchased the V8 of the software yesterday. It is running on a 2000 Server with a MSSQL database. It is installed and I get the successful connection to database screen but when I click to enter the admin. console I continually get:

"Connection string not saved in (data/config/aspbanner_unlimited_config.asp) file.
Most likey the data folder does not have proper permissions set on it.
That folder and all of the folders within it need (R,W,X,D) Permissions set for the anonymous webserver account.
These permissions can generally only be set by your hosting company."

I can save the string manually by hitting the button and I have checked that I have granted the proper access permissions. Any suggestions?

Ken
,

ok, I am home.. missed flight.. just got home an hour ago.

lets see.. I really need more info...

For starters are you using the delayed stats feature ? that is expirmental and could cause that problem

, I dont get it.. I am still looking into it..

I think this has something to do with your original experience when things would work and then not work.

something weird is going on
, (customer replied aug-sep 2005)

OK, you have old code then... I will send you some updated files that you can try.. let me know here if it solves the problem. , Your assumption was incorrect.... the login count has nothing to do with that. The login count only has one purpose and that is to limit the amount of times a user can log in if you want to do that.

Logging in for the 1st time means the time at which they 1st login and their session at the site is created... If there session ends and they come back and login they will get redirected because it will be the 1st time again.

Forms Based Authentication is all about sessions and session variables.

If you only want them redirected somewhere based on the login count that is something you have to work out and check on your own. It's very doable.

Seems like now I should have explained that better but I never thought anyone would think it meant what you thought.,

sorry,

there is not.. it gets really complicated
its practically a miracle it does what it does due to the nature of the web

perhaps with some modications it could do mroe but the current version pretty much does what it does

,

Hi,

 

I only just purchased the product and I would be very keen to

a) is the upgrade available very soon as I don't want to spend the time developing one and than find the other released shortly & 

b) would I only need to pay the difference for the upgrade or have I already downloaded the upgrade already.

I cant see what version I current have.

I look forward to your response.

ripcurlsurf38138.816099537,

Thanks, I'll take a look.

Nick

,

it's ok

one step at a time and at each step testing things.. then when you mess something up you can figure it out a lot easier

cwilliams38456.1106018519,

How do I change the character length for the description field?

,

This user is talking about preparing more than 100 pics at a time for an album that already exists and doing it using linux.

I asked the user to post the code here because I think it is interesting and it may help someone who is working with the app.

This article is not for everyone for a few reasons.

1.) The application can already mass import pics on it's own. It does 100 pics pretty quickly on a decent server. The built in method also resizes pictures and make low res thumbnails should your server support a supported ASP image resizing component. The method above simply rename pictures in a folder so the application will see them as part of an album.

2.) We don't support or recommend that anyone sets the application to use more than 100 pics per album. It is just not tuned for that and there will be issues. Please dont ask me what they are as it is complicated and I am not sure/dont remember what they all are.

3.) Your going to have to be familiar with linux to use the code shown above.

cwilliams38210.5694444444,

Running in parallel for testing is actually a smart way to do it, but the truth is you don't use anything from version 6 except the upgraded database (we have a tutorial on how to upgrade the database)

Version 7 was a drastic change /rewrite to all of the asp files that come with the application. So you will be starting out with fresh version 7 ".asp" files and folders... You will also find that once you get version 7 running that editing certain things like the look of the users area and the login screens is much easier to do.

That being said any of your own ".asp" pages that you protect use the same protection code they always did, so there will be no drastic changes needed there when you do finalize the upgrade.



If using MSACCESS as the database I suggest installing the application somewhere in your web and using a fresh ASPProtect 7 database. Once you are familiar with the setup and everything is working fine. Attempt the database conversion and when your done stick your converted database in there and see if everything is ok.

Also, if you already purchased the application download the latest version before doing the install. It's the same download URL. If you don't have it email me and I can hook you up. I have added some new features and fixed a couple minor things since it's release.

So far the feedback on version 7 has been awesome..

cwilliams38414.0133680556,

The version of aspbanner you have should not matter.

What you are doing here is wrong.

<PARAM NAME=movie VALUE=" http://www.innovationtools.com/aspbanner/aspbanner/banner_re direct.asp?Banner_ID=25">

PARAM NAME=movie is supposed to link to your ".swf" file.
And thats why all you see is black.

I don't think you quite understood all of that information fully.

Your ".swf" files needs to be coded in FLASH to link to the aspbanner redirect url. You don't change that flash calling code like that.

The ".swf" file links to the aspbanner redirect url which tracks the click and then redirects the user to the Link URL

You basically need to code your ".swf" flash file to go to that aspbanner URL or code your flash file so it can take a parameter for the url it clicks to (like the macromedia article talks about. This has to be done when editing the flash file in the flash editor before the file is saved.

If you dont have access to the original ".swf" to edit it and re-save it.. your out of luck as far as tracking clicks goes

,


Timecard Entry: 3/25/2006 4:39:51 PM

wildgal1(SIIE), Emails, Phone, email, Had disgusting pot pie. Note to self. stick with stoffers., speak with pat schermhorn about rates- fax instructions to renzi brothers about virtual email left message for jim- 401 k enriollment guy set up meeting for web site, At the business fair to see what Chris B. was calling about, busy, Checked modems at imc., CAR PROBLEMS, GraysFlowerShop.Com (billable), Many calls regarding modem issues. Lady called asking me if I would help her remove virus from system by going into registry., Bell CLEC Forms, steady, Finish migrating domains to iMail, did some reading from Beginning ASP , found out the news-Ron still working on my computer, radlog, dial up issues, posted, detail and deposit ready for bank-good size deposit, answered emerald questions , Reviewed softMLS contract and discussed with Tim Badour, helped chris m develop new power point., cleaning up ns1. ns2. ns6, mpts1 making soft router disks. exploring backup options, Interview, time Cards and Work Orders, handled a few email problems, CBT for cisco routers., Work on NYAB diagram. Also work database, organized order status re: Cortel, copy of edp received. worked on copying materials for marketing., Review quickbook procedures for billing & deposits, Building DB & upload component for ti.com rest. reviews., *Bram site re-work,

   Active Server Pages Rule The World
Contact Us  
All artwork, design & content contained in this site are Copyright 1998 - 2019 PowerASP.com and Christopher J. Williams
Banner ads ,other site logos, etc are copyright of their respective companies.
STATS Unless otherwise noted - All Rights Reserved.

PowerASP active server pages asp.net microsoft .net framework sdk learn asp what is asp tutorial learn asp.net CJWSoft ASPProtect ASPBanner ASPClassifieds www.aspclassifieds.com, www.powerasp.com,www.cjwsoft.com,www.aspphotogallery.com,www.codewanker.com,www.aspprotect.com,www.aspbanner.com