Home | Advertising Info124 USERS CURRENTLY ONLINE   
PowerASP
   Site Search Contact Us Thursday, October 17, 2019  

Active Server Pages what is asp programming how to sample asp example code scripts software asp forum mail sessions applications global.asa CJWSoft ASPProtect ASPBanner ASPClassifieds



Blog Entry: 3/25/2006 1:51:35 PM

A mod like this would improve tracking by leaps and bounds.

Do you think this addon would be availalbe anytime in the near future? If/when this feature or mod becomes availalbe, it certainly would be ideal if some script was made to import all the log file data.

,

Hello Chris,

I have switched to Alentus and have the permissions set correctly and Parent paths turned on.  I cannot figure out how to connect to the database.  Should I have the database in the aspprotect/data/database folder, or in the data folder that Alentus has in my root directory?  once that is determined, how do I decide what the path to that database is?  I have tried many things, but this is what the setup page tells me to enter in the data_conn file DBQ=D:\Websites\www.mysite.com\aspprotect\data\database\ASPP rotect_access2002.mdb;Driver={Microsoft Access Driver (*.mdb)};UID=Admin;Password=temp

Thank You

,



I think this addresses your question

http://support.cjwsoft.com/code/moreinfo144-1.htm

 

, My client has  a  list of  13,000 members that  have already  been assigned  ID's and passwords with a homegrown system.

When doing a bulk import, will we be able to retain the userid and password or will a new id be assigned during the bulk load?

Thanks in advance for your help.
,

nope ,sql server has nothing to do with this

I am talking about the folder pictures are stored in.. it needs modify permissions set for the internet guest account like those articles talk about

 

,

It happens at least once per hour or every time a banner is edited in the system by the admin.

Changing its frequency would be somewhat complicated. You'll have to make changes to the code in a few places and you will effect performance adversely by doing it more often as it will mean a lot more database queries which defeats the purpose of doing it once per hour to conserve resources. The reason is when you change the frequency of that you also change the frequency of the entire banner application variable caching system. It difficult to explain but it unlike most banner systems out there it basically fetches banner rotation info every so often instead of every single time your page needs a banner. It stores this rotation and cycling information in ultra fast application variables. The docs actually go over a little bit of how that process actually functions under "using the system / Setting Up Banners
"

Its a customization I just can not support and I do not recommend doing, but if you really want to you should look at the "aspbanner_inc.asp" file

this is the part that makes it happen at least once per hour (requires visitors to your site to happen obviously)... you'd have to cleverly recode it to work slightly more often

' Checks the time the banner data was last updated and basically updates it if an hour or more has passed
If Cint(Application("BannersLastUpdated")) <> Cint(Hour(time)) Then
%>
<!--#INCLUDE FILE="appinfo_inc.asp"-->
<%
End If


There may be more to changing this than that, but this is all I can tell you.

cwilliams38441.6427083333,

I had never noticed this before, but a customer sent me email to say that they had set up their aspclassifieds profile such  that they be contacted by email and not by phone.

However, in their ad, their phone number still appears. The lines in view_ad.asp that check for True values for the Contact_Via_Email and Contact_Via_Phone before displaying that information seem to always evaluate to True, regardless of their setting in the database.

I'm using an Access2000 DB for this. When I open the DB in access, I see the checkboxes correctly unchecked for phone and checked for email. However, if I do a quick test to display the retrieved values in the view_ad.asp (<%=contact_via_phone%> <%=contact_via_email%> they both display True.

What gives? I have had nightmares with Access and its weird handling of true/false 0/1 yes/no fields, but this is driving me nuts.

 

,

If you bought ASPBanner Unlimited Version 7.3 Before August/10/2004 this file needs to be updated.

It fixes a bug where the JavaScript method is not properlly closing an html Image tag. It can cause other hyperlinks on your web page to link to the same place the banner links to. This does not always happen but this fix is the way the code should be so it is best to update it.

Copy this file into your ASPBanner folder over the existing file of the same name.

2004-08-10_125304_injectbanner.zip

cwilliams38209.5378009259, Even if I try to upload the test file that was included with the system I still get the same error.

My host is using Windows 2003 Server.

Will send you a private email to see if the issues can be sorted out.

Thanks
, Well, hold everything.

Looks like I did it right. The latest user showed up in the correct group.

I guess the ASP pages had to refresh at the server or something...

It's still a great product, BTW. Almost five years for my enjoyable ride with ASPProtect!
,

Honestly cannot comment much about v7 since it was just installed on a new server.  We have been running 5.03 for years so I'm looking forward to the new features in v7.

Lance

,

Is this the full version 7.
Did you make any changes to the code ?
Is the User_ID field still an autonumber field in the Access database ?

I do not see how this could happen unless somehow the autonumber field setting for User_ID was changed in the database?

, I encountered the same problem and eventually found out that my Norton protection was not allowing scripts to work so I had to uncheck the setting before the banners reappeared., I have found the alternate databases and they do not work either. I then went back and changed the database path in the asptest page to connect to the 2000 and 2002 test databases and it connected successfully to both of those databases, just as it had successfully connected to the asptest.mdb., Hello dear Chris

I can login for the first time. I exit from the browser and then I cannot login again. This happens for every user.
I noticed that the values in the fields "Login_limit" and "Active" in the ASPP_Users table in the SQL changed to NULL and 0 when login and remained in those values after close the browser.
If manually I change the values it is ok but the problem repeated.
Thank you in advance.
,

I have just purchased ASP v7 and loaded.  Followed instructions.  Obtained codes not prob.  Get to single field login screen, enter password and following page appears:

Method Not Allowed

The requested method POST is not allowed for the URL /temp/aspprotect/password_admin/get_me_in.asp.

Added folder aspprotect under (temp web) folder - temp, but also tried under root folder of web site.

Still no luck.


Apache/1.3.27 Server at www.didac.co.uk Port 80
, How about the option to add an unsubscribe link to the end of newsletters that are sent out and a function that will uncheck the newletter field for that record if they click on the link?

Please??? 

Thanks,
Michelle  , My guess it they are runnign some sort of ad blocking software like norton ad blocking. Something on the client side blocking ads or anything with the word ad in it.

I would investigate that., Ok, for starters what is the real error ? Please read this.
http://support.cjwsoft.com/code/moreinfo11-1.htm

2nd I always recommend using CDOSYS before any other email component. All servers have it running by default and ASPProtect supports some a html editor if you use that component. I would give that a try as well. It's the best emailing option.
,

It probably is. You would have to look at the paypal documentation for IPN and see what needs to be changed in the form code.

You can get all that info from PayPal's website.

There are tons of variables and options you can use with all of their code.
They have detailed PDF files full of information on all of them.

 

cwilliams38459.9550925926, I have run into the same problem with streaming pdfs to the browser using the stream_download.asp example, but only when selecting the option to open the file directly into the browser (after it's streamed back) as opposed to saving it and then opening it (which works fine in Firefox and IE).  Then I ran across this Microsoft support article

http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q2 97822

It got me thinking that maybe a header needs to be included in stream_download.asp that tells the browser to specifically cache the file. Adding this suddenly got everything working

Response.CacheControl = "Public"

right after this line in the code

Response.ContentType = "application/octet-stream"

My asp is limited, but this seems to work at least for pdf documents.  Can someone confirm this?  The other question I have is if this is a solution, should the CacheControl be set to public or private.  Not sure on what the implications are.

Firefox by the way seems to open or save and open the file without this, so you are right that the implementation between the browsers is certainly different.

Tom

,

I did the initial steps of downloading the sql scripts and running it in Query Analyser, tables created fine.

I can login for the first time. I exit from the browser and then I cannot login again. This happens for every user and admin.
I noticed that the values in the fields "Login_limit" and "Active" in the ASPP_Users table in the SQL changed to NULL and 0 when login and remained in those values after close the browser.

So iam just struck not able to log in. Pls advice.

 

, aspprotect does not use a global.asa file

I would start by looking there and seeing what is going on ... with line 33

I dont see how it could be related to aspprotect in any way

Global.asa files fire on their own and what they do depends on what code is put in them,

that really does not make any sense...

I dont know what else to tell you as this really shouldn't be anything too difficult to sort out...

redirection based on criteria is not something aspprotect does by default... I try to help a bit... I've shown everyone how to do it in this thread...I know plenty of people doing it... I've done it myself... I know it works

let me ask you this... are you using ASPProtect 6 with the Option Pack ?
I assume you must be or you would not have the Groups feature ?
And you asked this question in the ASPProtect 6 section.

but then maybe your using 7.. I do not know

this should all work the same either way

,

The way the application ships there are no password confirmation areas anywhere ? Please be more specific as to what you have done and if any mods are involved ?

If you are talking about one of the MODS please realize they are not supported. http://support.cjwsoft.com/code/moreinfo459-1.htm

Even though they are not supported I look them over pretty closely and I know of no issue like you mentioned so I would suggest re-downloading the MOD. Perhaps you got a corrupt download or file.

,

sometimes those emails take a bit... all depend on wht you are using to send them and whether a pickup directory is involved

as for the other I do not know.. PM me the site details I can look

if it is a 2003 server parent paths must of course be enabled.. its a requirement of aspclassifieds

,

It appears there was a flag problem. When reading it into SQL Server, it converted the True/False in Access to 1/0 in SQL Server.

 

,

The protection code for my group3 is:

<!-- Begin ASPProtect Code -->
<!-- Groups with access to this page. ( * GP03 * ) -->
<% GROUPACCESS = "3" %>
<!--#INCLUDE FILE="check_user_inc.asp"-->
<!-- End ASPProtect Code -->

btw - sorry but I am using v7
and thanks for the assistance

, Is there somthing I need to change in the settings to get the hit count to update?,

I'm using ASPimage and have the maximum width set to 320 in the settings.  Also using SAFileUP ver. 4.0.

Files upload okay, and the script displays a confirmation that the image was resized to 320, but the actual image uploaded is displaying full size rather than reduced to 320.

Also, the thumbnails are not displayed in the Picture Manager. Would indicated ASPImage is not working or the script is not communicating with it.

Suggestions?

lancem38326.9070486111, Sorry, I can not provide a date..  I am last person that is organized enough to give any sort of release date on anything.

Could be next week, could be 2 years from now. I made two add-ons this week and they came out of no where. I had no plans to make them. etc etc.. they just happened.

If I told you 2 months from now I know it would not be done and you would be disappopinted so I am not saying anything. I will say if it turns out to be anything complex it will not be a free mod or it will be a feature of a new version.,
ok "ace45",

I just spent a bunch of time in your setup using SQL server and I didnt have a single issue. It all seems to be working perfectly to me.

I got into the system using the "get_me_in.asp" page like the instructions say to to.. then I deleted those two users you had there.

I created a new user called "admin".. then I edited that user to make him an admin.

I have logged off and back on as that user a bunch of times without issue.

admin
test


is the user info..

I just didnt see any problems whatsoever???

I also took the liberty of going into the settings page and setting all that up for you as well so all the url paths are right now and emailing from the application works.

I am going to wait an hour or so and try to log in a few more times but it honestly seems to be running perfectly to me. , It just sits there indefinitely without an error being returned. The only clue I have is that it seems to be connecting to the database when I try to log-in. I know this because I decided to erase the files and start again, but I could not delete the database because it was "in use". After I rebooted to clear that connection and erased the database, then re-did the install, the same condition exists after entering the key on the get_me_in.asp page. It just sits there indefinitely.,

its part of how the skins load.. regardless you got bigger problems here..

I am beginning to wonder if you unzipped the download correctly because I see things in folders they should not be in...

you should have ended up with a bunch of folders and files...

It you just ended up with a ton of files in one directory you did not unzip the zip file correctly... if so check your zip program settings.. I mean that error is because it is looking for a file in the skins folder that isn't there and it should be there

better yet, unzip the downloaded zip file using windows xp built in unzipping features which will do it correctly...

,

Actually, your whole site is like that.

http://www.bones.myftpsite.net/rfamilystuff/

You should definetly fix that..
I can't help ya with it though. You'll have to figure it out.

I know ya can do it...

later

 

cwilliams38394.7738657407,

when you get back to work.. your   "redirect.asp" needs the password include file at the top of it.. or that wont work either..

and of course those pages you send people to all need to be repaired

,

If you would like me to, I also have no problem going into your machine real quick via remote access and setting permissions / putting the right connecting string in there for you.

I need to go in as an administator though to set the permissions.

 

,

Editing the look of the login page.

In this version editing the look of the login page is very easy.
You can make this login page look exactly like you web site if you like.

You want to edit the "scripts/login_form_inc.asp" file.

It can be edited with any editor as long as the existing bits of server side code in it and the login form remain in tact.

The best thing to do is back it up before you start editing it.
Then if you goof it up you can revert back to the original.

If you edit this page with FrontPage enable the "show all" feature.
Its the little PIE sign in your icons. It will show the server side code as yellow things on the screen so you know where they are and can be careful not to delete them.

see screenshot

cwilliams38448.8132638889, I think I have successfully integrated Paypal but seem to have a slight issue. Once a person has entered the Paypal site but cancels their order, the ad is still placed on the site. The optimal way for my site to work would be to cancel the ad once the Paypal process has been cancelled. Any help would be great.

Thanks


,

Good Morning - I getting errors in my system log that says "404 file not found" for a number of files - Here are a few examples:

/aspprotect/password_admin/ drop1.gif
http://cidra.easycgi.com/ aspprotect/password_admin/edit.asp? User_ID=181
4 0.28%
/aspprotect/password_admin/ drop2.gif
http://cidra.easycgi.com/ aspprotect/password_admin/edit.asp? User_ID=181
4 0.28%
/aspprotect/password_admin/ left1.gif
http://cidra.easycgi.com/ aspprotect/password_admin/edit.asp? User_ID=181

I ideas on how to fix this?  Note: The system seems to be working fine, but I want my log files as clean as possible. 

Thanks.  shirley

,


Timecard Entry: 3/25/2006 1:51:35 PM

answered questions for a potential customer. helped some with email, travel back to lcayton- drop info to watertown office, Cleaned up the code within my changes that I made to make it look more appealing and easier to read for future updates. , efficiency spread sheets, weekly efficiency for all designers, Clayton to Wat'n commute, find out where k-is guys are on switch, Cleared space on NS2. Found old apache logs that could be deleted., Met with Jeff-Lewis Workforce staff about what they'd like for their site, Left-over Pizza and Chicken Wings, conference call with chr on e911, Ensure that Mt. Zion Assembly router is ready to be installed and hand off to Ben., worked on MLS roster page, LUNCH, Answered phones. Pretty busy. We seemed to have a problem somewhere in St Lawrence Co., *CommArts, Manager's Meeting, very slow night not that many calls at all did callbacks adn rad logs adn cleaned up the online page in emerald, ribbon cutting ceremony, w/Tim, Talked to 2 customers, one about modem strings and one about extending account. Second user asked a few questions about networks and RoadRunner vs DSL, talked for about 45 minutes concerning an internet cafe that he plans on setting up in Potsdam, possibly going through us. He plans on talking to someone today or tomorrow., training 3161 Nortel Onsite Training, Wrote out work orders for the Ads for the 10,000th customer for WDT and TI Sun, Since Dani usually has a big list on Fri, maybe Bill could come in from 9 to 5:30, and then a student, SoftGrade Presentation at BOCES, tarrif, called Vermont board and the Virgin Island board. looked over gen marketing info and comp, On phone w/Jumpin J` from Forever Broadcasting. Discussing updates to 790wtny and changes that they want made., **Agency Ideas - got a local group set up for Agency Ideas, Team meeting, check e-mail,

   Active Server Pages Rule The World
Contact Us  
All artwork, design & content contained in this site are Copyright 1998 - 2019 PowerASP.com and Christopher J. Williams
Banner ads ,other site logos, etc are copyright of their respective companies.
STATS Unless otherwise noted - All Rights Reserved.

PowerASP active server pages asp.net microsoft .net framework sdk learn asp what is asp tutorial learn asp.net CJWSoft ASPProtect ASPBanner ASPClassifieds www.aspclassifieds.com, www.powerasp.com,www.cjwsoft.com,www.aspphotogallery.com,www.codewanker.com,www.aspprotect.com,www.aspbanner.com