Home | Advertising Info300 USERS CURRENTLY ONLINE   
PowerASP
   Site Search Contact Us Thursday, October 17, 2019  

Active Server Pages help tutorial how to ASP Help ASP Tutorials ASP Programming ASP Code - ASP Free CJWSoft ASPProtect ASPBanner ASPClassifieds



Blog Entry: 3/25/2006 1:46:52 PM

humm.. can I possibly see this happening ?
any changes to that part of the code ?

 

, That worked...but when I tried importing the test user, the password was imported in an add formated...like it was encrypted, and I can't log in using the User ID that I imported.,



re-edit the banner to ensure your change was saved..

if it has been written to the database thats good.. if not it is a data connection issue most likely..

if it did get saved... though it usually should not take time to apply  it make take up to an hour for the change to take effect in the actual banner rotation.. give it a little time,

Banners no longer show up on my site ?

If banners were working fine and now they are just not showing up.
1st check to see that you are calling a valid zone with live banners in it.
If you are then most likely this it what hapened.

The web server must have crashed or lost power and now the application variables are in limbo/not working.

I have seen this happen 3 times. Twice on my own server when the power went out for 2 hours and once on a customers server.

Basically the application variable system gets all messed up because it was not shut down properlly.

The ways to possibly cure it are as follows.

 

Edit and save a banner in the system. Hopefully that gets things going again.
If not... keep reading for the more drastic cures..


Go to the command prompt on the server and type "iisreset"
Sometimes that is enough.

Reboot the server.
Sometimes that is enough.

Stop the web in the IIS console.
Sometimes that is enough.

Stop the individual processes for each web in iis
"you must really know what you doing and be very careful about doing this"

Remove and recreate new applications in IIS for the web in question.


And sometimes it just takes a combination of the things listed above and a few reboots. I don't know the best way to cure it but I do know why it happens and the steps listed above can get things back on track.

Again, this is because the server lost power or crashed as far as I know.
It was not allowed to shut down properly which sometimes happens.

You'll know things are ok again when you see your banners show up on your site.

cwilliams38295.0183101852,

Can I have the logon be in a top frame while having the protected pages displayed in a main frame?

Using frames with forms based authentication is not the best thing to be doing. Your much better off not using frames and using includes files to do a virtual frames sort of thing (search google) but if you are going to use frames I would suggest password protecting the frameset page as well as any pages it contains.

If you want to have a login form in a non protected top frame all the time.. that posts to a lower frame that is password protected.. you would do this
http://support.cjwsoft.com/code/moreinfo169-1.htm
but change the target of the form to one of your frames

personally though I think that would be a somewhat goofy setup to have going on


Also, how will it behave if a user moves in between a protected page to a public page and back to the protected page again?

As long as they have cookies enabled which is required for session variables to work... then you will have no issues because once they come back to a page they have permission to they will just be allowed in without login.. at least while that session is still active.. or for a longer time if they choose the remeber me option which keeps track of them with a cookie
.

Really, the best thing to do is expirment and see how things behave.

 

, Can you be more specific on the javascript I should look for? Can it be combined with ASPBanner?,

--------------------------------------------
(( TRY THIS AT YOUR OWN RISK !!))
--------------------------------------------

2004-08-19_122127_ASPBanner_V7.3_code_banner_encode_decode_m od.zip

This is an Expirmental MOD for ASPBanner Version 7.3 Only
Do not use it on other versions....

It encodes CODE Banner information before saving it into the application variables that handle banner rotation. It then decodes that information before displaying them on your web pages.

The reason for this is SOME very complex javascript does not always save correctly into the application variables that rotate banners (even when not using the JavaScript Method to display the banners)

This way the javascript or whatever you entered comes out on your web page exactly as you entered it and runs correctly.. but there is little more processing going on to handle the encoding and decoding. But its probably nothing to worry about and won't effect performance at all.

Unless your having a problem don't use this mod. It is not officially supported in any way.

-- DIRECTIONS --

( COPY THESE FILES INTO YOUR ASPBANNER DIRECTORY AND BACK UP ALL THE FILES THAT YOU WILL BE REPLACING ))
(( SO YOU CAN REVERT BACK IF THERE IS TROUBLE ))


If you are wondering if the "appinfo_inc.asp" included has the weight banner bug fix applied to it already. That is a bug mentioned in our forums

ALSO:

(( YOU CAN NOT USE THE INCLUDE METHODS OF CALLING BANNERS WITH THIS CODE ))

(( YOU CAN NOT USE THE JAVASCRIPT METHOD OF CALLING BANNERS WITH THIS CODE ))

(( USE ONE OF THE OTHER METHODS ))

cwilliams38229.4189930556,

Testing for XML Parser Support

the microsoft xml parser is generally installed by default on all new server setups..

It allows ASP code to make calls to other pages anywhere on the new as well as a lot of other handy things..

download and run this ".asp" page to verfiy that it is installed and be sure it is available for you to use

2004-12-10_132620_test_xmlparser.zip

Make sure you run it from your web server through the web browser

cwilliams38331.5621180556,

Let me put it this way.

My home page (default.asp) is an unprotected page.

When a user that has signed in on another (protected pages) and has the remember me checkbox checked closes the browser cookies should be set for the next time they return.

When the user opens their browser and returns  to my home page (default.asp), I'd like to put a message saying:
Welcome back <%Session ("Username")%>

How is this done?

,

All of the fields with the expected paths show the correct file structure, so now I've put them in them in the boxes

,

Have you thought about language file so users dont have to go into the code to put it in their language??

, I wasnt talking about the date for a banner ad.. I was talking about the date field in the database for a USER if there is one (I dont remember if that app had date fields for user or not and I am not at a computer to take a look)

If you do not know how to directly open up and edit the database then yes you should just make a new user, Just checked XML Parsing with your file. Got a clean bill of health on that: It's working.

Got the right code for the location of the ipn.asp in my paypal1.asp, from http:// all the way to .asp.

I think since everything is set up properly from the looks of things, I'll wait and see. If I get another one who flubs things, then I'll start the testing of the account. But if it goes through just fine, then maybe the Internet just hiccoughed on the first guy... thanks again!


,

Wondering what might be causing a long delay to display the login screen?  This does seem to be intermittent.  Could be server/ISP related? Have experienced enough times to justify posting this question.

I can count up to 20 seconds after clicking on the link.  After login all other selections zip right along without problem.

http://gibsoncity.us/aspbanner/

Thanks, Lance

lancem38319.6117939815,
That's excellent!
 
I did learn that parent paths were disabled on my test 2003 server...
 
But on the hosted server, it looks like parent paths are supported as I change the file location of the language file in the forum common.asp as such, and obviously moved the file as well:
 
from:
<!--#include file="language_files/language_file_inc.asp" -->
to:
<!--#include file="../language_file_inc.asp" -->
 
Everything seems to work fine and I thank you very much for you quick response!!!
 
Ok, time to buy...thanks again!
 
- Jason
 
, ok, I am going to do that in the next few hours. I cant do it right now as I have a few other business's and something else needs my attention right now.

Chris,

its a text file   you just edit it with notepad..  if ya mess it up ya put an original copy back in

no biggie either way

jump in there..

I just showed ya exactly what to change.. its a no brainer man
This is simple source code. It's meant to be edited and hacked.

The only reason I warn you is so you can't blame me later on if it effects something

I am just trying to help


If ya dont like that solution why not just use periods for the first name field.. or a dash or something... then nobody will really see it

or maybe store the company name in the first_name field

seems like clever things to try without changing the code..

good luck...

cwilliams38326.870474537,

Editing using Visual Studio.NET

Here are directions for editing the application using Visual Studio.NET
2002 or 2003 version.. either should work

Some of you are wondering why I didnt just give you the project files.
It is best you go through this process and really understand what is going on.
Also, I dont use VS 2002 so I wouldnt be able to give you project files that would work with that. Not to mention there is 100% chance my prject files wouldn't work for you anyway because of path differences and other things.


Anyway.. on with the instructions...

1st.. make sure IIS, ASP.NET, .NET Framework, and Visual Studio.NET are all installed correctly and up to date.

Open Visual Studio.NET

File -  New Project

Select a New Visual Basic ASP.NET web application.

give the new web to be created a name.. I called mine "aspprotectdotnet"

Hit Ok..

Now. once the project opens up we need to delete a few things in the solution explorer window.

So delete "webform1.aspx" , "deletestyles.css", "Global.asax", "AssemblyInfo.vb", and "web.config"

Basically all the files under the project...

Now... you should have the aspprotect.net files unzipped somewhere on you hard drive...

open that folder and select all the files and folders like so




Now drag those selected files and folders to the solution explorer window of Visual Studio.NET right on to the name of the web. In my case "aspprotectdotnet"

It might say this folder already contains a folder names Bins.. just tell it to copy over and continue on any prompts like that.

You'll notice your project is now populated.

Open up the references tab in the solution explorer window as we need to add some references to the dlls in the bin folder of this project. This is needed so the compile process and function correctly.

Right click on references.. click add reference
Then browse....browse on your hard drive to the location of the new web and the bin folder within it. 

In my case... "C:\Inetpub\wwwroot\aspprotectnet\bin"

Choose "aspprotectlicense.dll"

Hit open...

Now do the same thing again until you have added all the dlls in that bin folder to the references.. 

Now.. click add-references again and this time choose
"system.management" from the choices in the .NET tab

Once all of that is done your references should look like this




Now in the Visual Studio.NET menu system up top..

Choose Build - Build Solution

If you did everything right you will see something like this in the build window


------ Build started: Project: aspprotectdotnet, Configuration: Debug .NET ------

Preparing resources...
Updating references...
Performing main compilation...
Building satellite assemblies...

---------------------- Done ----------------------

Build: 1 succeeded, 0 failed, 0 skipped


You now have the visual studio side of things all set up.

To make the project actually run we now have to set some permissions and edit the web.config file.

Using windows explorer browse to the web the app is in. Right click on the "_database" folder and give that folder and all the child folders within it. Modify permissions for both the Anonymous webserver account and the ASPNET account. These accounts might not show up until you dig into the advanced tab and click find now to show all the accounts on the machine.

Permissions screen looks like this...



Once that is done go back the solution explorer window in visual studio.

Open the docs folder.. right click on "sysdiag.aspx" and choose view in browser.

It should complie the project again.. and then run that page in either the internal or external browser depending on how you have that set up.

That page will report back path information.
 "BTW.. for security reasons this page should be removed from any production server after installation is complete.. this is very important"
In my case it looks like this.

Probabale AppRootPhysicalPath
c:\inetpub\wwwroot\aspprotectdotnet

Probabale AppRootUrlPath
http://localhost/aspprotectdotnet

Probabale Path to Access Database
c:\inetpub\wwwroot\aspprotectdotnet\_database\aspprotectnet2 002.mdb

Now we need to edit the web.config file... your going to need to know some of the path information above.

In solution explorer double click on web.config.

Now edit the AppRootPhysicalPath, AppRootUrlPath, and CN keys accordingly.

In my case they will look like this.

<!-- PATHS USED BY THE SYSTEM -->
<add key="AppRootPhysicalPath" value="c:\inetpub\wwwroot\aspprotectdotnet" />
<add key="AppRootUrlPath" value="http://localhost/aspprotectdotnet" />

<!-- MICROSOFT ACCESS KEY -->
<add key="Cn" value="Driver={Microsoft Access Driver (*.mdb)};Dbq= c:\inetpub\wwwroot\aspprotectdotnet\_database\aspprotectnet2 002.mdb;Uid=admin;Pwd=" />

Now.. because our web is really not in the root of our virtual directory which starts at "inetpub/wwwroot" we need to edit another tag in this file.

Find the forms tag near the bottom.

<forms name=".aspprotect~net" loginUrl="/aspprotectlogin.aspx" protection="All" timeout="60" path="/" />

Change it to say this

<forms name=".aspprotect~net" loginUrl="/aspprotectdotnet/aspprotectlogin.aspx" protection="All" timeout="60" path="/" />

Notice tha part in bold that we added.

Now, you may also want to check the temp license key info while you are in that file and make sure it is not expired but I am not going to get into that here.

Now save and close that file and do a compile again.

In solution explorer open up the "aspprotectadmin" folder.
Right click on default.aspx and click browse

You should see the login prompt in your web browser..

Log in with   

admin
temp

all lower case

You should see the users screen of the application,

Click on the system info tab up in the top left... make sure all those paths are correct and save it.

Go to the settings page of the admin area. Make sure all those paths/settings are correct and save it.

Congratulations... you just set up a visual studio web project from scratch and our now ready to edit and compile an advanced web application.

From here on your on your own, but feel free to ask questions in the forums as you will probably get help from myself or others who own the software.


One last thing... because we are not in the true root of the web on the development machine the examples in the example folder will need the reference to the "protectpage.ascx" file modified before they will work

It will need to go from

Src="/protectpage.ascx"

 

to

 

Src="/aspprotectdotnet/protectpage.ascx"


If this app was installed in the true root of a domain on a real webserver.. you would not have to edit the forms tag in the web config file or change the paths in the examples as they would be correct the way they came

,

well, assuming that function works and is vbscript not vb
(if it is vb code it may need some conversion work)

anyway

in "users/add_new_account.asp"

you would put the code for that function anywhere in the page.. it does not matter where as long as it is in code tags <% %>

then.. right under this part of the same page

If Zipcode_Postal_Code_Required = True Then
 If  Zipcode_Postal_Code = "" Then
  ErrorMessage = ErrorMessage & Server.URLEncode("You need to enter a Zipcode_Postal_Code.\n\n")
 End IF
End If


add this

If Check_Postcode(Zipcode_Postal_Code) <> True Then
  ErrorMessage = ErrorMessage & Server.URLEncode("You need to enter a Valid Zipcode_Postal_Code.\n\n")
End If

No guarantees but that is the gist of it

cwilliams38381.6456828704,

glad it is working now

sorry ya had trouble.

cwilliams38418.6886342593,

I did the initial steps of downloading the sql scripts and running it in Query Analyser, tables created fine.

I can login for the first time. I exit from the browser and then I cannot login again. This happens for every user and admin.
I noticed that the values in the fields "Login_limit" and "Active" in the ASPP_Users table in the SQL changed to NULL and 0 when login and remained in those values after close the browser.

So iam just struck not able to log in. Pls advice.

 

, One month later, things are running very smoothly. Color me "satisfied customer"! ,

Here is the complete page with the error message:

============================================================ ===

Unspecified error



This means there is most likely a problem with the "ConnectionString" info that you specified.

If you are using a DSN-Less Connection with MSACCESS.

Check that the physical path to the database has been specified correctly.
It has to be perfect and correct. It cannot be specified using "http://" or by using "server.mappath".
It has to be specified like the following example.

ConnectionString = "DBQ=C:\Inetpub\wwwroot\advpass_pro\_database\passwords.mdb;Driver={Microsoft Access Driver (*.mdb)};UID=admin;PASSWORD=Xpass"

If this is running on an NT server or Win2000 Server make sure that permissions have been set on the database.
Only the server admins can do this. If you are not the admin you will have to ask for this to be done.



If you are using a System DSN

It is not set up correctly. Again, make sure the permissions have been set for the database and that the system DSN has been set up correctly by the server admins.

============================================================ ===

I am the only one on the site since I just transferred the files and in the testing phase.  It is using an MSAccess DB

 

,

... doesn't seem to be working on my site. I expect I did something wrong.

I've created some groups, "week", "month", and "year". Their IDS are 6, 5, and 4, respectivelty. When someone goes through the PayPal signup, he's assigned to one of those groups based on his subscription.

When I see a new subscriber and check the relevant group the person's supposed to be in, that person's not in that group. I'm adding them manually for now, but I'd sure like a solution for when I go to sleep...

My subscription code looks like this:

input type="hidden" name="custom" value="5,*4*,<% =User_ID %>

One-off code looks like this:

option selected value="7,4.95,1,*6*"

I've created the groups in my management console. Is there anywhere or anything else I'm missing?

,

ok, that probably means the physical path you have set for the logfile directory (in the admin settings area) is not correc t

the error pretty much means just what it says

 

 

,

ahhh ok.. I was going to wait till morning to answer this one..

glad ya figured it out

 

, did anyone find a way to get the descriptions to show under the image yet? ,

well, so far one other guy found one..

his, was some sort of weird character that was causing a line break or something though in my testing I just couldnt figure out what was going on

now for me to reproduce any error someone find with a password I need to know the key used and the password used

which make it real hard to troubleshoot

, sounds like the data/export folde does not have permissions,

Got any info for me on this ?

Chris

,

I have been able to successfully edit some text colors, but there seems to be one page that wont change the text color. Inside the users/ folder, the login.asp page, i cant seem to change the text color from ffffff to 000000 so it can be read on my background color. Every page in the script is correct but this one.

Thanks.

,

Thank you for the response to my question. In the mean time if I can figure any workaround I will post it here.

,

I did a sign up.. your verify URL is not saved/set in the application variables.

try saving the admin settings page again.. or reboot the server so the settings get reloaded

if you can make sure the web is it's own application in IIS

if it is your server do and "iisreset" from the command prompt

if all else fails you got iis application issues with the site... wait till tommoro to see if the setting gets loaded

,

IT worked just as cwilliams said. I did see the IP address being stored in the table but it didn't dawn on me that it was tied in to the view count, I tried it from a different IP address and it worked great .

Good coding Christopher

Thanks

John

, Just installed sofware everything works fine except I see no way to upload any photos.  There is no reference or link to allow an upload on any of the asp pages (I have surfed them all).  I am sure it is something simple, but I am not aware.  I am using SQL2000.,

[QUOTE=cwilliams]actually, passwords can be up to 75 characters long in ASPProtect.
the only requirement when entered from a non admin user is that they are at least 4 characters long.

what does MSAccess have to do with this ? Are you trying to convert and old system or something? I noticed you created and "old password" field in there ? Is there something I do not know about as far as what you are trying to do?

Passwords in version 7 are encrypted so I hope you understand all of that and realize you can not enter or change passwords right from SQL server. Also if you import info you must handle that accordingly and convert the passwords to encrypted format. [/QUOTE]

First off, I haven't imported anything from MS Access.. The only reason I mentioned it is cuz I thought initially it worked with Access and not SQL server.

I am not converting nor entering any data manually into the db, nor have I changed anything in the way the registration is made (don't know where the "Old password" has come from? thought it was a function you made?)

,

Hello Chris:

Let me run some more test if it's working on your end it should be on mine?  I have made some custom updates to the code but no in that area.

Thanks,
-
Ricardo

 

,

Thank you....  yes it does

 

Is there a limit in the number of Zones you can have in the database.

 

thanking you

,

Thought that was already done....

Back to the drawing board...

, OK, thanks..,


Timecard Entry: 3/25/2006 1:46:52 PM

Reviewing SoftMLS UML Mosel & Sample MS Partner white pages in prep. for writing a SoftMLS whitepapers., had taken timecards home to work on, Answerin phones, did some random TS stuff... not too busy. Only 2 calls on the 0770 line., budgets with tim, Called back people on voice mail. , Took stress management test, meeting with Mike Johnson, member of Buffalo board, recieving and installation of new equiepment, Review order's w/ Ivan. Call Bell Atlantic, straighten out addresses and questions on centrex installs. Talked w/ Samaritan to confirm appt. E-Mail, Voice-Mail., email, meet with fast lube usa-need poroposal- web site with location/services , Meeting with Jim about status in company, Manning NOC. Resetting modems. Watching network. Setting up domains., Took tech calls, got busy, checked DUI, RAD, AUQ, and voice mail when I could get a min. , finished cancels-god and did my own timecard., drop of check to ron dillion for supplies for staples, On phone w/Amy. Trouble-shooting tibait.com. No errors found., Checked all activities and kept eye on emonitor as it was going yellow all the time. Cleaned up around my station and did some typeing., started getting the NOC page flashy, training in Nortel Passport PVG 3108, New modem computer working well. , after hours at telergy., worked on adding upload manager to FX Caprara Trailers web site (fxcapraratrailers.com, programming, billable), catchup NOC stuff; help Beth on a few tough troubles, Scanned Dave Vs signiture, sized and emailed for Kelly, Finally quiet. Filled out my time card. The night was very busy and the calls were basically misc things again. , TIITC DB Admin, Called expiring users for today. Also answered tech calls., Had Steve and Tim clear up one other error that I was getting in the search for "'" All set now. , Network is down getting ''domain controller not found error''. Can't open any webs local or remote. Cleaned stock room while waiting, removed table from desk so office door can open correctly. Testing java-scripts I found for various form verifications.,

   Active Server Pages Rule The World
Contact Us  
All artwork, design & content contained in this site are Copyright 1998 - 2019 PowerASP.com and Christopher J. Williams
Banner ads ,other site logos, etc are copyright of their respective companies.
STATS Unless otherwise noted - All Rights Reserved.

Active Server Pages ASP ASP.NET .aspx .ascx Web HTML Developer Internet Microsoft Web Services Visual Studio .NET CJWSoft ASPProtect ASPBanner ASPClassifieds www.aspclassifieds.com, www.powerasp.com,www.cjwsoft.com,www.aspphotogallery.com,www.codewanker.com,www.aspprotect.com,www.aspbanner.com