Home | Advertising Info110 USERS CURRENTLY ONLINE   
PowerASP
   Site Search Contact Us Sunday, May 29, 2022  

vbscript active server pages ASP vbscript SQL database informix oracle SQL Server Perl CGI Delphi PHP source code code sample samples program CJWSoft ASPProtect ASPBanner ASPClassifieds



Blog Entry: 3/25/2006 1:35:40 PM

Can you incorporate a secure log in within the scripting.  I would like the account information to be secure without having to have the whole site using running through a secure (https://) path.  If this is possible, the scripting is perfect!

,

Sorry, should have added,  if i change the connection string, i can also get this...

[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

,



If a picture does not show after uploading it is one of the following things.

The upload method chosen is not supported on the server
or
The physical path specified to the pictures folder is not correct.
or
The URL to the Pictures folder is not correct.
or
Permissions to the pictures folder have not been set properly


Here is more information on how permissions are set.

http://support.cjwsoft.com/code/moreinfo136-1.htm
http://support.cjwsoft.com/code/moreinfo56-1.htm

Without more information and the settings you have entered and chosen that is all I can offer for now.

, okay thanks,

You should not have single quotes around the "-1" because Album_Active is not a string field in the database. It's true/false or bit field in the database depending on the database you are using (MSSQL or ACCESS)

I'd do it a little more like this I think.

SELECT COUNT(Album_ID) AS Alb_Count FROM " & tbl_label_albums & " WHERE User_ID = " & CmdListUsers("User_ID") & " AND Album_Active = 1"

I took out the parentheses as well since I dont believe they are needed in a simple case like this

but is hard to say unless your the one testing it... my version might have a mistake as I am a little rusty with my SQL at the moment

also: in case your wondering...
depending on the situation and the odbc drivers the 1 and -1 should work either way but sometimes it's picky and you have to do it one way or the other

cwilliams38433.0564930556,

That would not happen unless you added a target to the login form or you're code had a base target set.

Like so..

<base target="_blank">

I would really need more detailed information. It's nothing the system does the way it ships under normal circumstances. For example you shouldn't see that behavior in any of the example protected ".asp" pages

that is unless you have something odd going on with your browser settings or you made changes to the login form or code around it causing it. (or you are using frames and dont have some of the targets and what not set correctly)

My guess is that it has to be something you added or did, but I really need to know more to offer more than that.

 

cwilliams38419.7687152778, OK, so I misread the instructions. Wouldn't have been the first time that happened...  but I just had an account get created, guy then paid, and... no activation. I had to go in the next day and do that by hand. What should I do to look for troubleshooting on the issue? I've got all the default directories set up and all the files where they should be. What next? ,

Hi all

I logged in myself to my website, and I tried to log in to another with same username and password. But I was able to log in again.

It was supposed to block me from logging in, but it let me to log in.

there has got to be some configurations I must have missed.

Could you instruct me on this Concurrrent login so mine works as well...

thanks

 

,

as far as permissions are concerned I wrote two large articles about permissions that cover everything in detail on how to properly set them

http://support.cjwsoft.com/code/info11.htm

see the windows 2003 and windows xp permission threads

From things you are saying I assume this is your server. My comments about the path looking funny are because very few commercial hosts would use the "c:\inetpub\wwwroot\" directory. If you are using that and that is correct info then that is fine.

as for knowing whether or not the filesystem object is working the best thing to do is to try to write  a text file somewhere in your web and see if it works. Testing something under the most basic scenario is the key to troubleshooting asp issues.

http://www.devasp.com/samples/writetofile.asp

,

It's seems to work fine after renaming the file, rebuilding the application, and editing the web.config file to point to login.aspx. It looks like I can use your fine product and thanks again for the help. It was unusually easy. Merry Christmas…

, Yes, I created it  using the scripts.
, recently i've been getting a lot of unspecified errors.  i've been running aspbanner for about a year and a half now.  i don't know what would have caused all these problems.  also, for some reason it won't maintain my log-in, ever time i got from page to page or try to submit a form it asks me log-in again.

Jason S.
cwilliams38389.8791550926, Verison 8 is superior in every way and the code is much more optimized so yes I think it would handle it better. It is still a lot of banners on one page though which means a lot of hits to the database if you call them all individually with zone calling code. SQL server would make sense more than MSACCESS.

Now, the only reason I said make one zone for all those banners on the home page is because a banner has to be associated with a zone. It would make sense to put them all in one because if you just tracked the clicks like I mentioned you really wouldnt be using the zone except for maybe when you go to view stats. ,

I just added this line to the paypal1.asp page

<input type="hidden" name="currency_code" value="CAD">

and it worked.  Clearly other values can be entered for other currencies.  Everything was listed in this manual https://www.paypal.com/en_US/pdf/subscriptions.pdf.


Cheers
Roy


 
,

It sounds like permissions... to the database folder specifically
they are not correct

It could also be that your odbc drivers are very new and you are not using a new enough version of the access Database. I recommened using the 2002-2003 verison of MSACCESS


Now.. if using a SQL Server Database permissions to certain tables are handled in enterpise manager

cwilliams38303.5892708333, now. I just went to that url and this is the error I see which shows me there is a character in the source code that shouldnt be there which is causing the page to halt.

Looks like a "carrot".

 

Microsoft VBScript compilation error '800a0400'

Expected statement

D:\CLIENTS\RKLARMAN\DRSWEISBERG\PASSWORD_ADMIN\../dataconn_i nc.asp, line 18

<%
^
, here is the next response to this which was emailed to me but should have been posted here


From: Mo Afifi
Sent: Sunday, October 23, 2005 4:47 PM
To: CJWSoft Support Info
Subject: Re: CJWSoft Support Info : SSL - Verisign Certifcates

Hello,

Thank you for responding to my posting. In the second line of your response you said “not start them off at an http:// url". I think what you meant is to "not start them off at an https:// url". If this is your intention then I agree with you 100%. I have revised my pages so the users will go first to a non-https page and then make a choice either to use secure or non-secure access. Please note that the site is not intended to be completely SSL protected but only the sign up pages. I have another problem though when I click on the "Secure Log In" and enter my log in information; the entire subsequent URLs will have https:// in them which I could not shake off. As I said the intention was to use the https for sign in only.

 I realize that this issue does not have any thing to do with your product, but any input will be appreciated. Best,

 Mo

,

as far as sql goes if you follow the instructions with give for setting up a new database you shouldnt have any issues and permissions should be already set. because we handle that in the sql script we give you.. "its a good thing to look at and it is pretty easy to understand what is going on""

however using another account could cause permissions issues.."yes, even sa"     basically the username your using needs datareader and datawriter permissions to all tables used by the photo gallery system and you probably have to go specifically set them usin ght e security tab for your database in enterprise manager. This is more of SQL server 101 than anything to do with the Photo Gallery Code so I am not going to get into it too deeply, but that is definetly the issue.  Permissions...

cwilliams38303.6065740741, ASPProtect version 6 does not officially support any sort of redirection or is it a feature.

You can however do redirection after login with some basic ASP if-else statements and ASP redirects. Basically you check the session variables after successful login and send users where based on that info. You of course also need to protect any pages you send users to and make sure any people that aren't supposed to go there do not go there directly and bypass your security.

I highly frown on Redirecting during login (In my opinion it is poor site design and it defeats the purpose of dynamic web pages, there is seldom a good reason to even need to do it if you design your site well) but you can check out this thread which should give you lots of good information.

http://support.cjwsoft.com/code/code_info.asp?TID=17&KW= redirect,

This is amazing. You replied to question within minutes. Thanks for showing such a professionalism.

 

,

If you still cant see the upload buttons after checking the settings send me a PM with the info and I will take a look at your installation. It will have to be up on a live server of course.

, OK, thanks..,

A mod like this would improve tracking by leaps and bounds.

Do you think this addon would be availalbe anytime in the near future? If/when this feature or mod becomes availalbe, it certainly would be ideal if some script was made to import all the log file data.

,

One last thing..

This is bad

http://www.bones.myftpsite.net/rfamilystuff/pictures/

there are .asp files in there people can run that you dont want people running..

u should delete the asp files in there or turn off directory listing...

take care,

CJW

, humm,

thats a new one.. something is very wrong.

Please show me screenshots of exactly what happens and what you see. It does not make any sense so I need more info or I least need it described in more detail.,

I'm trying to use CDOSYS.

It seems to work fine on the web page, however the mail never gets
delivered.

I can see my messages sitting in c:\inetpub\mailroot\pickup but they never leave it.

I found another folder after doing a search for "pickup".... it is:
d:\program files\Exchsrvr\Mailroot\vsi 1\PickUp     If I paste the files
into there, they get delivered.

How can I get the email to be delivered without doing the cut and paste?

I've tried it both with and without authorization.

I am running a Windows 2000 server with Exchange 2000.

Thanks.

,

These are 4 valid examples of calling a flash movie.

The more simple examples may cause problems for people that don't have the flash plugin installed. I really do not know as I am no flash expert. All these work fine for me. Of course I have the latest flash plugin installed. Perhaps some of you can shed some light in this. The 3rd and 4rth examples are obviously only slightly different and mention different versions of flash as far as downloading the plugin goes.

 

<EMBED src=" http://www.aspbanner.com/test/aspbanner/images/banners/power asp.swf" WIDTH="468" HEIGHT="60">

 

 

<object width="120" height="22">
<param name="movie" value=" http://www.aspbanner.com/test/aspbanner/images/banners/power asp.swf">
<embed src=" http://www.aspbanner.com/test/aspbanner/images/banners/power asp.swf" width="468" height="60">
</embed>
</object>

 

 

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase=" http://download.macromedia.com/pub/shockwave/cabs/flash/swfl ash.cab#version=6,0,40,0"WIDTH="468 " HEIGHT="60" id="myMovieName">
<PARAM NAME=movie VALUE=" http://www.aspbanner.com/test/aspbanner/images/banners/power asp.swf">
<PARAM NAME=quality VALUE=high>
<PARAM NAME=bgcolor VALUE=#FFFFFF>
<EMBED src=" http://www.aspbanner.com/test/aspbanner/images/banners/power asp.swf" quality=high bgcolor=#FFFFFF WIDTH="468" HEIGHT="60" NAME="mybannername" ALIGN="" TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer">
</EMBED>
</OBJECT>

 

 

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase=" http://active.macromedia.com/flash2/cabs/swflash.cab#version =4,0,0,0" ID=banner WIDTH="468" HEIGHT="60">
 <PARAM NAME=movie VALUE=" http://www.aspbanner.com/test/aspbanner/images/banners/power asp.swf">
 <PARAM NAME=quality VALUE=high>
 <PARAM NAME=bgcolor VALUE=#FFFFFF>
 <embed src=" http://www.aspbanner.com/test/aspbanner/images/banners/power asp.swf" quality="high" bgcolor="#3CBDCD" WIDTH="468" HEIGHT="60" TYPE="application/x-shockwave-flash" PLUGINSPAGE=" http://www.macromedia.com/shockwave/download/index.cgi?P1_Pr od_Version=ShockwaveFlash">
</OBJECT>

cwilliams38089.6129513889,

I have imported like 50,000 users into an access database when testing... it took like 4-5 minutes but worked..

course it really all depends on the setup how many you can get away with

something must still be wrong

have you tried just importing 1 or 2 users for troubleshooting sake ?

I would also recommend that after any timeout you reboot the server or at the very least do an "iisreset" to get things back to normal

,

Thanks.

 

clark

 

,

To hopefully wrap this thread up...

This user showed me his site and things were working for me as they should.

We came to the conlusion that the weird behavior he was experiencing was because he was using AutoComplete in Internet Explorer....

It was automatically filling in the fields with his username/password that he had autocomplete save.

So it was a web browser usage issue.. not the code.

cwilliams38165.5102546296,

ahhh ok.. I was going to wait till morning to answer this one..

glad ya figured it out

 

,

I think its great to share a mod.

I will have  few with the new album.

,

I have written asp.net application pages- obviously i knew what viewstate was, or else when they made a mistake on that page it would not have saved their filled in info. Same thing for after they submitted, when they hit the back button their info would be gone.

For someone who wrote this software it seems you are not able to do simple things. Im begining to think you didn't write it. The only reason no one else asked this many questions is possibly because they didnt NEED the functions i am TRYING to do.

I know how the log boxes work. Esp. reg ASP... they all allow you to enter your username and password and then when you hit submit it gets verified and transfers you to your destination. ASP.NET has that capability also.. i didn't purchase a program to go and have to re-write it in visual studio. It would take me longer to re-write YOUR code than it would to have LEARNED ASP.NET and made MY OWN.

The program seems to have some great complex features, however, your not able to incorporate this easy login from a diff. page function... fishy

,

Hi all,

I have the photo gallery set up at www.kashabowieoutposts.com/gallery

It's great - love to work with it.

But I've never been able to get those with just User permissions to be able to upload... Only an administrator is successful in uploading.  This was no problem in the past, but now this client would like to give their guests a means to share their pictures on their site - so now I have to figure out the bug...

... this is the error I keep getting...

Your upload did not succeed, most likely because your browser does not support Upload via this mechanism.

Your browser must support a standard called RFC 1867. Please check with your browser vendor for support of this standard.

 

------- anyone else experienced this?

Many thanks all!!

Doug

,

I have been using this solution for over a year now and think its great, however I recently logged on to add a banner and when I clciked on the link that opens a window, displaying all the gifs in the directory../images/banners/, now images showed up, however they do exist in that directory.

I recently upgraded my computer and am now using windows XP...could that be the problem?

 

Thanks

 

,

Hi Chris

Unfortunately the bl**dy server was down and unavailable for 17 hrs so I couldnt even get to see what the settings were!

It is on, the relevant users appear to have all rights for the data/tempstats folder.

I'm guessing you're going to suggest turning it off and see if the problem still appears.


Colin

,

Just to let you know that i figured out my problem. I had to modify the connection in the email code and get the correct path from my provider.

I hope you enjoyed your vacation.

Thank you
Adam

,

Well. fontpage publishing is evil. That you have found out.

Do not use it. It usually wont work right when running asp code locally and also at the server because of differences with the paths and virtual directory structure. etc etc etc

You can definetly use frontpage to connect to the web site live and drag and drop files into it/edit them... but the sooner you stop using the publishing feature the better off you will be.

,

Just having the database with members does not protect the page.  You need to add the appropriate code to every page you want to restrict access to.

You need to click on the Groups tab in Admin. 
Click on Generate PW protection code. 
Click on the basic button if you don't want to include levels or groups or choose a level or group(s) and click the appropriate button. 
Paste the code that's generated  into the top of an ASP page in code view.

Is that what you're looking for? 

Michelle

,

its a text file   you just edit it with notepad..  if ya mess it up ya put an original copy back in

no biggie either way

jump in there..

I just showed ya exactly what to change.. its a no brainer man
This is simple source code. It's meant to be edited and hacked.

The only reason I warn you is so you can't blame me later on if it effects something

I am just trying to help


If ya dont like that solution why not just use periods for the first name field.. or a dash or something... then nobody will really see it

or maybe store the company name in the first_name field

seems like clever things to try without changing the code..

good luck...

cwilliams38326.870474537,


Timecard Entry: 3/25/2006 1:35:40 PM

watertown office, DIRP, management meeting, did radlogs and some callbacks had many calls for tech questions, continuance with Nortel meeting UEIMAS presentation, dpec and,NT training, Printin invoices and reports. Answering phones, Bundle to go live Wednesday. Getting numbers for drop offs to channel partners. JC to print more brochures today for Monday. Spoke with Andrea and Michelle about possibly implementing new system for reports from partners on employees to clean up Emerald. , dms 500 channel banks, Talking with Bell tech. Waiting for them to run more tests on the equipment., S&S on phone, last name fields not showing in their directory listings. found and fixed the problem., Timecard system, Marketing, develop weekly status report for Allen, Calls regarding dial up issues. In all cases it was the customers computer that was causing the problem. 1 customer will be calling the manufacturer for support. , Tried to locate the Channel Partner Programs Sales and Marketing agreement for Tara to print more, techcalls, Radlog, BASTAS FLOWERS SCAN 20 PHOTOS AND WORK ON LAYOUT, B: meet w/Adam re:EveryDayDad.com development/ASP, Nortel, incoming calls, travel to clayton, radlog, dial up issues, meet w/Adam re: 24DD/Energy Initiatives development status, talking with Beth and Roger Morgan as to the problem with the circuit. Called in a ticket and escalated it. Let Howard and voice mail and a email on the situation., lowville up and down all day long, emails and callbacks for soon to expires. General billing., Team meeting, Calls from the guys at Albany presentation about the pword for Wstarmls.com. Talked to Steve about whether there would be any reason why they wouldn't be able to log on., searching web for Y2K pic for newsletter,

   Active Server Pages Rule The World
Contact Us  
All artwork, design & content contained in this site are Copyright © 1998 - 2022 PowerASP.com and Christopher J. Williams
Banner ads ,other site logos, etc are copyright of their respective companies.
STATS Unless otherwise noted - All Rights Reserved.

Active Server Pages asp source code database MS SQL MS Access .mdb adovbs.inc cookies calendar codes sql commands scripts asp programming tutorials iis web server components CJWSoft ASPProtect ASPBanner ASPClassifieds www.aspclassifieds.com, www.powerasp.com,www.cjwsoft.com,www.aspphotogallery.com,www.codewanker.com,www.aspprotect.com,www.aspbanner.com