Home | Advertising Info113 USERS CURRENTLY ONLINE   
PowerASP
   Site Search Contact Us Thursday, October 17, 2019  

Active Server Pages asp search engine active server page asp application components tutorial CJWSoft ASPProtect ASPBanner ASPClassifieds



Blog Entry: 3/25/2006 1:47:25 PM

Your going to have a lot of problems and a lot of the code will have to be re-written.

There are a lot of things in the the code that the MYSQL database system does not support or has issues with . I know because I once made a version of ASPBanner work with MYSQL and it took weeks of work to get it stable.

Null field types can cause problems... but mostly ADO updates which I don't think MYSQL supports at all. All of the ADO stuff would have have to be rewritten.. etc etc

That's probably why you cant get much of the code to write to the database.


Here is a generic example.

An update to an existing record using ADO
http://www.powerasp.com/content/database/ado_update.asp

And update to an existing record using an update query.
http://www.powerasp.com/content/database/using_update.asp

All through the the code the ADO updates would have to converted to update queries which means a lot of work.

I used ADO a lot because I like it and it is little easier to validate data before it is written to the database.

It is also a little easier for customers to understand when they look at the code.


Anyway....

The app just was not designed to work with MYSQL.
It was specifically designed to work with MSSQL and MSACCESS only.

This holds true for all of our applications.

Your running off an IIS 5 Server so I would suggest just using MSACCESS as the database. The Photo Gallery app will run very well using MSACCESS. 

,

I think I've got it to work somewhat.  I modified the 2checkout1 & 2 asp file to use and pass Product_id.  It now identifies the product correctly.  I'm good fo now. Thanks for the info though.

-Jason

,



its a text file   you just edit it with notepad..  if ya mess it up ya put an original copy back in

no biggie either way

jump in there..

I just showed ya exactly what to change.. its a no brainer man
This is simple source code. It's meant to be edited and hacked.

The only reason I warn you is so you can't blame me later on if it effects something

I am just trying to help


If ya dont like that solution why not just use periods for the first name field.. or a dash or something... then nobody will really see it

or maybe store the company name in the first_name field

seems like clever things to try without changing the code..

good luck...

cwilliams38326.870474537,

The main users screen... the 1st screen you see when you go to the admin area..  where you email an individual user..

The settings I am referring to being the various emailing settings on the settings screen, The settings you showed me.

As for emailing via a remote server over dsl. It may not be working because the ISP's block the port (25) to stop people from running email servers over their dsl.

Your POP3 works because POP3 uses port 110.

If you want to send emails from your local server on your dsl you should probably install the SMTP service of IIS if you have not and send emails using that with CDOSYS. Either that or get a commerical DSL account with a static IP that allows for running email servers.

,

Hello:

 

When using the Mass Mail feature and selecting the Users to ‘Active’ and the Access Level I want to send to the system will still send e-mails to the ‘Inactive’ users from the same Access Level.

 

In other words it sends to everyone in the Access Level regardless if you choose “Active” only.

 

Any ideas to correct?

 

Thanks,

-Ricardo

, just FYI -- i added in a new data table into the database.  I havent finished implementing the whole thing across the entire site, but it wasn't too difficult.  Once I have all of the functionality complete I'll post some details.  Some of the changes are the addition of a new album nav style which combines style 2 and some of the features of the new data table.

Very easy app to work with guys.
,

well, I was curious myself so I just tried it.

Good news is it worked just as I thought.

Only problem is your changing things to allow authentication info to be passed over the net in a url. If you can live with the security implications then it will work. I mean a sniffer could see that and end up knowing the username and password.. not likely but just putting that out there.

Of course now that I think about it unless you are running under SSL (https://) when you log in normally that info is in the post info anyway and possible to get at.. course not right out in the open like when you put it in the url and less likely to be noticed.

As long as your not doing it to access critical areas like the admin pages... and you monitor the log files once in a while it's probably nothing to worry about.

, Not sure how to response.write the session variable,

I am getting the same error looking at the previous post, I looked in settings and my Registration-URL is pointing at the correct location.

 

Is there any other thoughts on this issue

Thank you!

Matt2112

, We would like to give a member an opportunity to upload an image when on their profile page. How does this work with the photo option on the settings page? Is this the intended usage? Thank You. ,

MySQL Database Setup

Use of MySQL is 100% unsupported as you can see from the site.
http://www.aspbanner.com/mysql.htm

Even still I recently had an encouter with an extremely Jerky person (read the thread above for more on that) and because of him I am adding this tutorial showing one way to set things up on a windows server using the official MySQL tools available.

Let me just say as well that there are 100's of 3rd party tools to work with MySQL databases and many ways to create the database and apply the database creation script. In the past it had to be done via the command line, but now there are a lot of visual tools you can do it with. Furthermore all hosting companies set MySQL up differently and give you access to varius interfaces to manage it which are all different, and that is primarily why I do not support it. How the hell could I support all those different interfaces many of which are totally custom?

The fact is 99% of the people that purchased ASPBanner to use with MySQL have done so without issue and love how it runs. Regardless here is how I set up a working MySQL database on a windows server proving it does indeed run with a MySQL database.

1st of all if you are setting up the server you need to download some things from http://www.mysql.com/ 
(btw: you local developers can install this on XP Pro as well if you like.)

For this article we are going to download the current non beta windows version of MySQL which is 5.0. ALso known as the Windows Essentials (x86) download. It's about 17 meg.

Because ASPBanner uses the MyODBC drivers (now called Connector/ODBC) to connect to the MySQL database you need to download those as well. (Our site flat out says this is required for MySQL use)

So I download those from here. http://dev.mysql.com/downloads/connector/odbc/3.51.html
Version 3.51 has been the current version for a couple years now.
You want the windows driver install which is about 2 meg.

The two downloads should look like this.



Now, on the webserver you run the version 5 setup (mysql-essential-5.0.19-win32.msi) I will guide you through it step by setp.



Hit Next



I am going to choose typical for the sake of this article.

Hit Next



Hit Next



Wait for a bit



I skipped this part.



Choose to configure the MySQL Now

Hit Finish

Hit Next



I am going to choose Detailed Configuration



Since I am on a development machine for this install I am going to choose Developer Machine. For a Real Server choose one of the server options.



For this article I am going to choose Multifunctional Database: You may want to pick one of the other options. That is up to you. ASPBanner will work under any of the scenarios.



I am going to leave the location at its default

Hit Next



Since this is a development machine these options are fine.

Hit Next



These options are fine as well.

Hit Next



Standard is fine for my development machine.

Hit Next



I am going to choose both of these options. The 1st one is Important and should be enabled on a real server so MySQL always runs. The 2nd is not so important.

Hit Next



Set the "root" password and do not forget it. You will need it to manage your MySQL server. I do not advise creating an anonymous account unless it is a development server and you just do not care. Whether you enable root access from remote machines or not is up to you so do some research on that. For this articles needs I am not choosing it.

Hit Next



Hit Execute and wait



If all goes well you will see this. (I actually got an error message about not being able to connect... I went to to Administrative tools/services and restarted the MySQL service and hit retry which cured that... it probably only did this to me since I have installed this before.. new installs probably will not have any trouble)

Hit Finish

Your done.. You just installed the MySQL Server (TIP: its usally a good idea to reboot and make sure the MySQL servce is running by default)

Now, moving on..

Lets install the MyODBC drivers.. (now called Connector/ODBC)

This one is a bit of a no-brainer so I am not going to go into detail.
Just run (mysql-connector-odbc-3.51.12-win32.msi) and run through all the defaults until it is done.. Choose typical when that comes up.

Your done setting up MyODBC on the server. If its not your server I guess you don't need to worry about installing all of this as its your hosts job to do that.

, Hi, lets start with about when did you purchase and download the application so I know what version of the code you have.,

When I add a user, I can not activat it.

It sends me back to log on and will now allow me to log in as admin???

I can restart the APP and log in as Admin, but the user I added

is still not activated??

My system will also not allow me to set the Stay Loged in FLag.

It just ignores it....

 

 

, ok, I got it all sorted out for you and aspupload seems to be working now.

Basically they seem to have an odd version of it installed and I had to tweak the code a little. I also uploaded the server info page in the admin area to test for it.

Just back up the gallery folder so you have a backup copy of the modified code.

CJW ,

I noticed that is grabbing the wrong URL for some reason. Even when i mouse over the URL its somehow getting the users sub directory. How.. i dont know... when i erase that users in the url it works perfectly.

I am looking at the code in the .vb file and i dont see anything that could be causing it to do that... but then again i am no programmer LOL

Its obviously kicking in that users subdirectory somehow... what are your thoughts?

,

Humm, I dont see how moving to a new server could have anything to do with that.

What method of displaying the banners are you using. Perhaps try some of the other ones.

Don't use the javascript method with a javascript based ad like google.. that's for sure.

cwilliams38454.8903472222, from the import page in the admin area.

The import/export file must be tab delimited with no text qualifiers. The 1st row containing field names and the following each being a new user. To create your own import file it must be in this exact format. To find out what field names and their order are simply create an export file using ASPProtect and take a look at it. You can also import that text file into MSACCESS. ,

The file check_user_inc.asp as the lines: (which include Session("groups")

 Here we set some valus about the user into session variables
   Session("PasswordAccess") = "Yes"
   Session("Access_Level") = CmdCheckUser("Access_Level")
   Session("Admin") = CmdCheckUser("Admin")
   Session("Active") = CmdCheckUser("Active")
   Session("Expiration_Date") = Expiration_Date
   Session("User_ID") = CmdCheckUser("User_ID")
   Session("Groups") = CmdCheckUser("Groups")
   Session("Redirection_URL") = CmdCheckUser("Redirection_URL")
   Session("Password") = RC4(CmdCheckUser("Password"), PasswordEncryptionKey)
   Session("Username") = CmdCheckUser("Username")

,

Understood.... can you point me to a place where there are other methods of calling banners?  Do you mean not use Flash?  I am new to this and will need some pushing over the cliff!

 

Thanks

Dave

,

It's MS Access, Version 7 (the Full one).

Anyway, I had inadvertently changed the user_id field type to "number".  When I changed it back to "autonumber", everything went back to normal.

 

Thanks you very much for your quick reply and sorry to have bothered you.

,

Also.. if you want to customize each person's experience individually it really does not make sense to use groups or access levels for that purpose alone.

I mean, why bother making a group or access level for every user and worrying about keeping track of it all when you can just access the available session info about the user to create dynamic pages specific to that user.

http://support.cjwsoft.com/forum/forum_posts.asp?TID=198& ; ; ; ;PN=1

That is why that information is there.


You can of course use some combination of the two technologies as well should you have groups of users that you want to have a slightly different experience.

cwilliams38433.6259606481,

Thanks.

 

clark

 

,

- I am using the original files that came with the software.
- The software ads items to the database flawlessly.
- ASPImage works great.

- When I try to remove an ad or an image it says it's been removed.
- The ad does not show up on the site anymore.
- BUT, when looking at the sql database the ad is still listed there.

Why is the software not deleting the columns from the database and the images from folder?

Note: My other tables for other projects, in the database, allow me to delete them.

, does emailing work at the simplest level.. ??

meaning does a user get an email when you send an email from the admin users screen ?

if emails are not sending it could very well be the setting you have chosen for emails in the settings.

the best thing to do is keep trying to send an email there and try different emails settings until you get something that works... even when I do installs for people I often have to try a lot of various things before I get emails to send.. like picking different components and trying different things for the email server address because what they tell me is often wrong

also, sometimes emails get sent but depending on where they go they may get deleted as spam.. aol, hotmail, msn, and yahoo are famous for that , I checked the SQL table and had 1 banner with no zone ID. I added it in
directly through the SQL interface and now it seems to be ok.,

Hi,

The source code comes with it.
They are the.vb files.

I don't give out any project files for reasons stated in the article below.

Please read this in full if you want to edit the application in Visual Studio.NET

http://support.cjwsoft.com/code/moreinfo85-1.htm

,

I'll try to help when I get back tues night,, see the contact page for info on where I am
http://www.cjwsoft.com/contact/default.asp?Subject=CJWSoft+G eneral+Inquiry

,

Banners no longer show up on my site ?

If banners were working fine and now they are just not showing up.
1st check to see that you are calling a valid zone with live banners in it.
If you are then most likely this it what hapened.

The web server must have crashed or lost power and now the application variables are in limbo/not working.

I have seen this happen 3 times. Twice on my own server when the power went out for 2 hours and once on a customers server.

Basically the application variable system gets all messed up because it was not shut down properlly.

The ways to possibly cure it are as follows.

 

Edit and save a banner in the system. Hopefully that gets things going again.
If not... keep reading for the more drastic cures..


Go to the command prompt on the server and type "iisreset"
Sometimes that is enough.

Reboot the server.
Sometimes that is enough.

Stop the web in the IIS console.
Sometimes that is enough.

Stop the individual processes for each web in iis
"you must really know what you doing and be very careful about doing this"

Remove and recreate new applications in IIS for the web in question.


And sometimes it just takes a combination of the things listed above and a few reboots. I don't know the best way to cure it but I do know why it happens and the steps listed above can get things back on track.

Again, this is because the server lost power or crashed as far as I know.
It was not allowed to shut down properly which sometimes happens.

You'll know things are ok again when you see your banners show up on your site.

cwilliams38295.0183101852,

When a user 1st signs up a proper case function is run on certain fields.
This is only once on user signup and never done in the admin area.

It's goal is to keep things entered in Proper Case,

so if someone enters "chris williams" it becomes "Chris Williams"

It's not perfect but it helps a lot to keep the data clean and more consistent. Since it only happens during registration those values can be changed later by the admin or the user if someone wants to.

The function is only applied to the fields that it makes sense to apply it to.... 
In your case adding a drop down menu means you want exactly what is in your drop down to appear so you wouldn't want it happening.

That being said, it is really easy to remove this situation from any field it is happening to during registration.

So edit "users/add_new_account.asp" with a text editor

find

CmdAddUser.Fields("Company_Name") = PCase(Company_Name)

and change it to

CmdAddUser.Fields("Company_Name") = Company_Name

That is all that is needed to made the change

cwilliams38421.5069328704, Its one of the drwbacks of the encyrption.. sometimes.. VERY RARELY  it will produce things that cause a problem and will not work.

It is something I am doing more research on .., >>1. What is telling paypal to return the info to the ipn.asp page for processing?  Is that something I have to set up in my paypal account?

Nevermind on this question.  I found the notify_url variable.  :-\

Thanks,
Michelle
, If you PM your site info and I can go in and troubleshoot. I have no more ideas. Usually people have zero issues installating this application as I got it pretty tweaked so I need to see what is going on in order to help., When a logged in user with specific group rights tries to look at a page that has different group membership requirements the Login screen comes up giving them an opportunity to login with different rights to view the page.  If you log in again with your current user name the same login screen returns with the added words something to the effect of "Access Denied, you dont have group rights to this page...".

The only way to get back to the previous page is to hit the back button on the browser (there is not a back button on the denied page). 

I would really rather not even present the "login again" screen to a user but just have a custom page that says "access denied" of my own design with a back button on it.  Is this an option provided for in ASPProtect currently?  I did not see it in the admin section settings tab.  Is there a separate "login again" asp file that is being used for this group access deny message that I could alter, or does it always have to be the login asp file?
Or would this require me modifying the check_user_inc.asp file around line 356 to change this behavior (I don't want to screw up any other stuff though...).

Thanks!!

Oh, PS.  just a quick check...it looks like if a user is an "admin" he automatically gets to see all group pages regardless of which set of group numbers are assigned in his user account...is that right?





, that is good news... good guess on my part I guess

anyway, try this for your latest issue.

http://support.cjwsoft.com/code/code_info.asp?TID=340&KW =%2D1,

How do I change the character length for the description field?

,

I used Dreamweaver4 to make my site is there anything I can do to make it work?

,

ok, well as far as what else to try I already told you..

you need to manually compare all those field settings with the sql script and make sure they all got set correctly...

you also need to tell me what email/name you ordered the application under... before I will continue this support with you.. at this point I don't know if you purchased the application or if you are using the unsupported lite version

 

,

Your users with Internet Explorer may have received the "Page Expired" error.  For ASPProtect users, it happens when  the user is not logged on and tries to invoke the target page. check_user_inc.asp puts up the login form, and IE sees it as part of the target page.  Any later attempt to Back up and reload from cache gives the errror. 

My solution was, after successful login, instead of falling through the bottom of check_user_inc.asp and running the target page, I issue a re-direct to reload the target page. I also added META tags on the dynamic login form to say no-cache and expire now, so the re-direct really does reload the target page. This time, of course, check_user_inc.asp does not need to put up the login form, and the new target page in cache contains no form at all.  So, IE will not give a Page Expired error when Backing up to it later.

Netscape, and I gather other browsers, do not behave the same way, so I limited the solution to IE.  Also, the solution only works if the target page has no form of its own.

I'm uploading my customized version of check_user_inc.asp that contains this solution.  (In it, I also used the Javascript focus method to place the "cursor" in the Username field when the login form loads.)

2004-11-22_050940_check_user_inc.zip

cwilliams38313.494537037,

did you fix it because I see all the pictures just fine ?

http://mcintoshcounty.org/real_estate/view_item.asp?Ad_ID=1

 

,

Here is what I have in settings.

ServerSoftware Microsoft-IIS/6.0
ServerName www.107threnegades.com
ServerProtocol HTTP/1.1
PathInfo /gallery/gallery_admin
PathTranslated d:\hosting\arisky1\gallery\gallery_admin
FILE SYSTEM OBJECT Installed
ADODB (ActiveX Data Object) Version: 1.2 Installed  
CDONTS Version: 2.80 Installed  
SMTPMail Not Installed  
JMail Not Installed  
AspEmail Not Installed  
AspMail Not Installed  
SAFILEUP Not Installed  
Dundas Upload Not Installed  
ASPImage Not Installed  
AspJpeg Version: 1.4.0.1 Installed  
ImgWriter Not Installed  
Script Engine
Type VBScript
Version 5.6
Build 8515

I do not even see ASPUpload listed but when I run the test_asp_components.asp from the extras/more_component_info folder, it shows that it is installed.

67 Upload
Installed
Persits - ASPUpload
68 Image
Installed
Persits - AspJpeg

 

,


Timecard Entry: 3/25/2006 1:47:25 PM

Correct LOC on cash flow report, FIXED FORM FOR WDT , office work, *BHCP, Chittenden, Monitor system for Y2K, worked on cortland database, ABM - modifications to ad for Vacation guide, scan in and add new picture, phones steady but not busy, Problem w/ bearlovers domain, caused when Randy moved it without notification, Not much different than the other two nights. Not that busy, but had moments of steadiness. Did callbacks on expiring users and radlog., cc report, cancellation of invoices, callbacks from voicemail, checked emails, taking sign ups, answering phone., meet at IDA , training, continued incidents, sales meeting, fixing a imc-net domain for Lisa Hunneyman, customer had about 4 websites going in various directories (bad setup done a LONG time ago. Consolidated them into one website for the customer., lunch, Email responses again. , team meeting, General, Meeting w/Steves parents, lunch, and setting up Anthonys computer for development (format, install os and software, etc.), callbacks, personal, post office, phones / logins /e-mails, Busy as heck, phones were ringing off the hook, then bad stuff happened..., Researching articles, making some calls for appointments and checking into some courses, read 24 hour ASP book and worked with examples, Review notes from A-Bay meeting and begin proposal for web enhancements, Team Meeting,

   Active Server Pages Rule The World
Contact Us  
All artwork, design & content contained in this site are Copyright © 1998 - 2019 PowerASP.com and Christopher J. Williams
Banner ads ,other site logos, etc are copyright of their respective companies.
STATS Unless otherwise noted - All Rights Reserved.

Active Server Pages ASP control controls class classes module script Scripts applet CJWSoft ASPProtect ASPBanner ASPClassifieds www.aspclassifieds.com, www.powerasp.com,www.cjwsoft.com,www.aspphotogallery.com,www.codewanker.com,www.aspprotect.com,www.aspbanner.com