Home | Advertising Info117 USERS CURRENTLY ONLINE   
PowerASP
   Site Search Contact Us Thursday, October 17, 2019  

Active Server Pages ASP a directory of ASP tutorials applications scripts components and articles for the novice to professional developer. CJWSoft ASPProtect ASPBanner ASPClassifieds



Blog Entry: 3/25/2006 1:49:47 PM

No, Unfortunately.
I have seen your messages.
I have not edited the code at all.
Tomorrow I will install the sql database again from your script as I did before and I will try again. I will send all the details.
Thank you again.
,

I'm having another problem-hopefully it's a quick fix.

 

If i try to login as a user in the Http://localhost/aspprotectlogin.aspx page

 

it tries to go to a page: default.aspx    

 

Server Error in '/' Application.


The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested Url: /default.aspx

 

When i log in as admin from the aspprotectadmin/default.aspx that works fine...

where should the user be sent when they log in? Am i supposed to specify that or is it automatic? Why isnt it working for me? I dont believe i changed any settings that correspond to that either

,



Things have now changed I found out godaddy has persitis aspUPload and aspjpeg as value added products, I have the aspjpeg working but have been unable to upload when using aspUPload, everything works fine with the vbscript method so I think my permissions are correct. Whenever you get a chance, any help would be appreciated.

Thanks

Mark

,

humm, I dont know.

If you want me too I would be glad to go into your web site and troubleshoot. If so PM me the info I need and I will take a look and see if I can figure it out.

CJW

 

,

As an update to this thread I fixed the "upload_post.asp" page quite some time ago but forgot to post the updated file here.

So here it is.

2005-09-16_165913_upload_post.zip

,

Hope the wedding went well.  I have one this weekend.

I was successful at performing an upload.  The free upload software was either not configure properly (probably) or not working.  I downloaded the trial version of softartisan's upload (which is like over $300) and it started working. 

Can more than one photo be uploaded at one time (like a whole folder full of photos) or does each have to be done individually?

,


ok, here's a test page:
http://www.galvinelectricity.org/download_link.asp

user: test
password: test

Our company just got new computers, so everyone here has the same set-up, all Dells, all about 3 weeks old, all Windows XP.

But I did realize after reading your post that I am using Firefox and everyone else was using IE. When I used IE, I was able to duplicate the error.

But, alas, I am unable to resolve it. Client will be using IE, no doubt.

, actually, looks like its 8.95 a month now for a pretty slick plan
http://www.alentus.com/hosting/valueplan.asp, it probably means the page you are trying to protect is (not in an iis application or not in the same iis application) which it needs to be

for a situation like using ASPProtect you really want your root of your virtual directory set up as one big application in IIS. (after you inquired about it your hosting company probably went and set the ASPProtect folder as an application in IIS which means any pages you protect need to be in there as well. (truth is they should have had your entire web starting from the root set as one in the 1st place..... its standard practice for any experienced hosting company) cwilliams38456.9306828704,

no, there is not not.

If you wanted to to that you would have to add some code to check their album count in the database and not allow them to make a new album if they were at the limit.

cwilliams38433.0233680556,

Hi Chris,

 

Thank you for your prompt response.

Our current project requires alot of customization.

 

Yes, the error is probably a data problem and not due to your code, because we needed to make modifications to the database.  But that's why debugging would be helpful.

 

Basically our intent to modify the asp protect code stems from the fact that our client doesn’t want certain fields to be recorded or to appear: address, city, state, zip etc…

 

We are happy to be able to modify the HTML, but we also want to modify some other default behavior, such as which page opens when the "cancel" button is hit in the editaccountinfo.aspx page.

 

 

, [QUOTE=sdunham]

My hosting company uses ASPEMAIL - and I am trying to setup the mailing settings on ASPPROTECT - but cant seem to get it to work.   I've tried many different options - here are two that are the closest - but have issues:

1. If I use the settings:

email component: aspemail

Mail remote server: my internal server name

*no smtp authentication

email mail notification - my email address on my internal server

***I get the following results:

       I can get get notified when a new user logs in, email a user from aspprotect user screen if they are in my company and have a valid email -- but I can not send to the outside world - I get an relay prohibited error.

2. If i try to change the setting to use the Hosting Website email server - I get the following results:  I dont get notified when a new user registers, I cant send to internal company people - but I can send to the outside world.

**any suggestions on what to do? I'm trying to work with the people who manage the mail servers - but since I dont know anything about them - its a bit difficult.

 

[/QUOTE]

The relay error is because when you send emails outside your email domain smtp authentication is required.

I suggest trying to use CDOSYS with the smtp authentication option. CDOSYS is on all servers by default and is really the way to go. Use a real email account and password to send the emails through the server.  Be sure to check smtp authentication for cdosys and to specify all that info for your email account and password in the settings screen.

If you want to know about CDOSYS read my article.
http://www.powerasp.com/content/new/sending_email_cdosys.asp

,

While my host says the permissions are now correct....its still trying to download the setup ASP file instead of executing it.

I really need to get this application working asap too.  I noticed the purchasing page said that install came free.....so any help would reaallly be great.

 

re

,

here is the answer
http://www.iisanswers.com/IIS51.htm

 

CDONTS

CDONTS (Colloaborative Data Objects for NT Server) is a feature of NT and W2K that allows you to easily send mail from a web page using the SMTP server. The simplicity of the code and widespread availability of free scripts employing CDONTS has resulted in  CDONTS being widely adopted.

Quite a surprise to many administrators to discover that IIS 5.1 does not support CDONTS as do IIS 4.0 and IIS 5.0. This has been replaced by CDOSYS which appears to have more capability, but it is not quite as simple to use. See: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q195 683 for more details.

You can enable CDONTS on XP by copying CDONTS.DLL from a Windows 2000 installation to your XP system’s Windows\System32 folder (default name). Then at command prompt Windows\System32 run REGSRV32 CDONTS.DLL. The extent of my testing on this was to deliver one piece of mail, so this should not be construed as a complete analysis of the effectiveness of this technique.

cwilliams38392.8260300926, We would like to give a member an opportunity to upload an image when on their profile page. How does this work with the photo option on the settings page? Is this the intended usage? Thank You. ,

Wondering what might be causing a long delay to display the login screen?  This does seem to be intermittent.  Could be server/ISP related? Have experienced enough times to justify posting this question.

I can count up to 20 seconds after clicking on the link.  After login all other selections zip right along without problem.

http://gibsoncity.us/aspbanner/

Thanks, Lance

lancem38319.6117939815,

ASPProtect and PayPal are fully automated and ready to go.
Accounts will automatically get activated after payment.

We actually do not tell you to put nothing in the PayPal system for the IPN URL. Something has to be there or PayPal will not let you enable IPN. We actually tell you in you PayPal settings to turn on IPN and make up an IPN url because something has to go there. (I think we suggested making a blank asp page on you're site to send it to) It really doesn't matter where you send that but it might as well be a valid page on your site to avoid any 404 errors in your logs when a non ASPProtect payment comes in.

You see, we dont set that IPN url set in the PayPal system because each ASPProtect signup script directory (single payment and subcription) uses it own IPN url and that all gets set on the fly by the aspprotect system. There is a way to overide the defaul IPN url is what I am saying.

Also:
A  lot of people already have something there and we didn't want the ASPProtect system to interfere with things they already had going on.

cwilliams38421.530787037,

You need to make sure you created the SQL database using the SQL scripts we provide and that no errors occur whatsoever. That is extremely important. You must use our SQL creation scripts.

Then, when you create the user you need to go back to that user and make sure you check the admin account and save that user again. (many times when setting up a system for someone I find myself forgetting that step and then I have to go back in and check the admin box for the user I created.)

And of course create the user from the ASPProtect admin area web interface. Do not add the user to the database manually because you will have no way to enter the password correct as it is encrypted. And do not change the encryption key after making the user/.

It would also be wise to check the SQL server database at every step to make sure the user info gets created and that all the field info looks correct for the most part.

You also want to be sure to specify SQL as the database type side the connection string info as the SQL directions go over

a remote sql server should not an issue.

thats really all I can think of right now

, I would like to change this file name to the typical Login.aspx, how to do this? I have a VS 2003 but need instrutions if that's the route to go.,

Chris, I'm having problems getting this to work. When I plug in the redirect URL and then try to load the web page, the Flash ad never loads successfully - just its black background in the 468 x 60 space. Here's an example of what I'm seeing:

http://www.innovationtools.com/Articles/ArticleHeadlines.asp

Just keep refreshing the page until the black rectangle appears. And here is the code I've loaded for this flash ad:

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
 codebase=" http://active.macromedia.com/flash2/cabs/swflash.cab#version =4,0,0,0" ID=banner WIDTH="468" HEIGHT="60">
 <PARAM NAME=movie VALUE=" http://www.innovationtools.com/aspbanner/aspbanner/banner_re direct.asp?Banner_ID=25">
 <PARAM NAME=quality VALUE=high>
 <PARAM NAME=bgcolor VALUE=#000000>
 <embed src=" http://www.innovationtools.com/aspbanner/aspbanner/images/ba nners/mindmatters_innovation3.swf "
quality="high" bgcolor="#3CBDCD" WIDTH="468" HEIGHT="60" TYPE="application/x-shockwave-flash" PLUGINSPAGE=" http://www.macromedia.com/shockwave/download/index.cgi?P1_Pr od_Version=ShockwaveFlash">
</OBJECT>

What am I doing wrong? By the way, I'm using the standard version of ASPBanner. Not sure of the version, but it dates from about 2002.

, Oh, it does seem to put the photo in the correct directory.,

Banners no longer show up on my site ?

If banners were working fine and now they are just not showing up.
1st check to see that you are calling a valid zone with live banners in it.
If you are then most likely this it what hapened.

The web server must have crashed or lost power and now the application variables are in limbo/not working.

I have seen this happen a few times.

Basically the application variable system gets messed up because it was not shut down properlly.

The way to cure it are as follows.

Edit and save a banner in the system. Hopefully that gets things going again.

, you can edit the look of it but because it is licensed software the links to aspbanner and the aspbanner logo.. etc etc must remain  otherwise change it all you like.,

You can mix and match banner calling methods all you want.
Try it and see what happens.

However, the only method that is going to work on non ".asp" pages is the javascript or the new iframe method listed in the support forums.

 

cwilliams38209.532349537,

You not getting a blank page.. you getting an error. You just can't see it because it appears you edited the page background to black.

error '80040211'

/aspprotect/scripts/emailing_subs_inc.asp, line 174

,

basically one at a time because of limitations of the file uploads that browsers can support 

more on that here
http://www.aspphotogallery.com/pro_add_ons.asp


An Admins can however ftp a bunch of pics to the import folder and import them into any album all at once pretty easily

 

,

Has anyone used the aspmail function to send and recieve emails from within your forms? If so what string did you use in the aspmail_host field in the connections database.

thank you
adam

, Totally 100% depends on what you are doing.. you certainly can't be renaming any fields unless you plan on editing a lot of code that references them. Adding new fields is nothing to worry about.

Also, you really should post a question like this under the forum section for the application you are referring to as well as specify exactly what changes you are talking about. For example I don't even know what application you are referring to.

I sell about 8 applications.,

The Pop-Up Javascript Date Pickers will only show up of your server's regional settings are set to one of two lCID values.

1033 which is English - United States
mm/dd/yyyy date format

or

2057 which is English - United Kingdom
dd/mm/yyyy date format

 

Many servers are set to run the default LCID which is 2048 so the banner system will not show the date pickers.

This setting can however be easily overwritten when using the ASPBanner system.

Edit the "config_inc.asp" file with a text editor.

Add this code between the <% and %> tags.
Near the top is good 

Session.LCID = 1033

or

Session.LCID = 2057

depending on what date format you are looking to use

Save the file and go edit a banner. The date pickers should be there now.

cwilliams38325.7403125, This user has notified me that the issue has been resolved based on what I told him.,

edited due to inappropriate content

,

All this being said installing the desktop version of SQL may be a little tricky as it may complain that your SA account needs a strict password.

The solution is to run the SQL Desktop setup.exe with some parameters specifying a password for the SA account.

So you go to the command prompt or make a shortcut to the setup file and run something like this

setup.exe SAPWD="YourPassword"

minus the quotes...

I got that info from this article and it worked fine
http://www.experts-exchange.com/Databases/Q_21036508.html

The other thing to remember is it might take a reboot to actually see the SQL server icon running in the taskbar. You may also need to go into the administrative services and enable the "SQLSERVERAGENT" as well as set its startup type to "automatic"

And a reboot here and there..

Whammo... your in business...

, I have found the alternate databases and they do not work either. I then went back and changed the database path in the asptest page to connect to the 2000 and 2002 test databases and it connected successfully to both of those databases, just as it had successfully connected to the asptest.mdb.,

Password Retrieval System

I'm trying to setup the email functionality and have the following settings:

Email_Component : CDOSYS (Using Remote Server)

Mail Remote Server: the smtp server in my Outlook account

Use SMTP Authentication: Checked

SMTPUsername: the email address in my Outlook account

SMTPPassword: the password in my Outlook account

Email Notification: sales@tradersreports.com

But I get this when I send the request for via missing password info.

CDO.Message.1 error '80040213'

The transport failed to connect to the server.

/aspprotect/scripts/emailing_subs_inc.asp, line 174

This is running on Windows 2000 server.

Any ideas?

Warren

, that erorr in no way means what it says.. it is just a generic error because something failed.

if you want to PM me info on how to get into your site and I will take a look.. I don't think it is something that can be figured out otherwise especially when you are not telling much about what is going on. There are a lot of factors and settings that are relevant. , FYI. There is a typo in the upgrade (6.0 to 7.0) instructions. It specifies adding a field named "passwords". Should be "password".,

I will actually explain how to set access_levels and/or groups...

in "users/add_new_account.asp"

carefully edit with a text editor
find this part
 
CmdAddUser.Fields("Access_Level") = "4"
 
that is where the acess level gets set...
you can change the level or remove that line all together if you dont want one set
 
now for groups you would add this line in the same area
 
CmdAddUser.Fields("Groups") = "*3*"
 
or
 
CmdAddUser.Fields("Groups") = "*1*,*2*,*3*"

Groups access for a user is stored in one field in the database like you see above. If you are confused what you should be saving in that field I suggest simply setting a user to whatever groups you want via the admin area and then looking in the database to see what got saved in that field. It's pretty simple really how they are stored.

*1*,*5*,*9*

that user would be a member of groups 1,5, and 9
, humm, I am curious

If these people are employees and sales reps why are are you using expiration dates at all ? and why the renewing issues... etc etc

I am sure there is a reason but you did not explain.

it might help me to better understand and possibly think about new features for new versions in the future.,

Yea.. that error is totally because the asp pages are looking for fields in the database that are not there.. and causing a nasty loop.

 

if using the option pack you must go over the directions very carefully...
Make sure everything works step by step..

After upgrading to option pack code you either need to upgrade the database from the base system or use the newer database provided with the option pack.

Then.. you want to test every function of the groups.. if pages act slow and seem odd... especially the groups page and edit users page..
Then your not using a valid database. Either you didnt upgrade the old one, are not using the new one, or your connecting to an older verison by accident and not realizing it.

That's pretty much it...

cwilliams38300.5555671296,
Christopher,
 
I have a follow-up to this question.
 
Is there a way to get the photo descriptions to save with actual spaces instead of the HTML space code all of the time?
 
I know that is does this if you hit Enter while typing a description, because it creates a 'br' tag. The main reason I am asking is because if the user does not enter a line break, the description is saved a single long string  and the pic_window.asp page is generated with one long description which makes the page very wide.
 
I tried to get around this by changing the description style in pic_window.asp to reflect a value like 50% or 200 pixels, and I have tried putting it into a table with a fixed width, but there is no effect.
 
Thanks!
 
- Jason
,


Timecard Entry: 3/25/2006 1:49:47 PM

research mrtg / snmp / perl .. tchs and as5800, spreadsheet with what I have, Painted; panted some more. Then painted again., cleaned up office and took trash out of cans that needed it.. vaccumed Ron and Jim's office tech room and outside rug in the hallway, Talk to Paul Eadi from Telergy about SoftCalendar, Mikeco- changes to web site- changes given to Tom- Mike will send picture to upload to site quote 1 to 3 hours, Logging total controls and resetting modems., Prospective hosting customer, Lunch at Tin Pan, research streaming media methods (WNCS), Finalized and submitted Staples order. Readied money for Clayton. Filed customer paperwork. Answered phone., did some radlogs. signed up a customer, clpeeb (SIIE), Checked the Watertown 2360 modem pool., * BHCP, Began drawing layout for mls poster. Spoke with Matt Hickey (Nevel Realtor) about web site hosting. Faxed price listing to him and referred to CB to call., TRAVEL BACK TO WATERTOWN TOTAL MILES 524 MILES TRAVELED TODAY, email,voice mail, Gisco web & A/P, cancels again, Helping Matt with a few things on admin.gisco.net and typing some of the instructions on making a kickass webserver., MLS site enhancements, read and sent emails, Customers and Dept. Mail, Jim showed me how to install the Konica printer onto Darryl's computer, and then I practiced on the Test Machine., changes for web site Bob Nelson/given to Tom emailed changes for web site hopkin homes/given to jason Changes for davidson/given to to tim for jason , server moves with Sleepless Randy, email, voicemail, call backs, trouble reoports, new domain setups, misc, Meeting w/ Cisco rep and NEC rep regarding future business and products., team meeting,

   Active Server Pages Rule The World
Contact Us  
All artwork, design & content contained in this site are Copyright © 1998 - 2019 PowerASP.com and Christopher J. Williams
Banner ads ,other site logos, etc are copyright of their respective companies.
STATS Unless otherwise noted - All Rights Reserved.

Active Server Pages help tutorial how to ASP Help ASP Tutorials ASP Programming ASP Code - ASP Free CJWSoft ASPProtect ASPBanner ASPClassifieds www.aspclassifieds.com, www.powerasp.com,www.cjwsoft.com,www.aspphotogallery.com,www.codewanker.com,www.aspprotect.com,www.aspbanner.com